1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail localhost.localdomain issue

Discussion in 'Plesk for Linux - 8.x and Older' started by gameon, Sep 19, 2005.

  1. gameon

    gameon Guest

    0
     
    our plesk sever continues to be listed on the cdl spam list due to the email header containing the localhost.localdomian name rather than another domain name. This is a server that host s a few virtual websites/email accounts.

    I tried to change the host name to mydomain.com in the /etc/sysconfig/network file, however, the ftp access would not work so I switched it back to localhost.localdomain. I have not changed /etc/hosts as I heard that changing the 127.0.0.1 entry from localhost.localdomain would cause problems with other programs.

    ANy thoughts? I desperately need to have the server delisted from the cbl list. I have contacted cbl and they state the localhost.localdomain is the issue..
     
  2. webteamHQ

    webteamHQ Guest

    0
     
    Repeated CBL listing Cause: localhost.localdomain

    I am having the same problem, all my configs are out of the box, and here is what CBL said:

    sending email in such a way as to strongly indicate that the IP itself was operating an open http or socks proxy, or a trojan spam package.

    You will need to examine the machine for a spam trojan or open proxy. Up-to-date anti-virus tools are essential.

    If the IP is a NAT firewall, we strongly recommend configuring the firewall to prevent machines on your network connecting to the Internet on port 25, except for machines that are supposed to be mail servers.

    Note: Your IP Address was found to be using the following name during connections:

    localhost.localdomain

    Which is an illegal name according to the RFC2821 SMTP mail protocol standards. RFC2821 requires that the machines claim names that are a fully qualified domain names or IP addresses enclosed in square brackets.

    This is usually a spamware/trojan infection. In the off chance that it isn't, we recommend you examine your mail server configuration and ensure that your mail server is using an appropriate domain name.

    Variations on "localhost" at best suggest that you're running relatively old mail server software that hasn't been configured.

    Apparently old versions of sendmail (particularly those on Linux), and the Perl Net::SMTP module default to this value, and need to be configured properly.

    Apparently the "MXLookup" plugin for SpamPal helos as localhost.

    Turn it off until you can get a fixed version. It is unknown as yet whether a fixed version is available.

    Useful links:

    http://www.ftc.gov/secureyourserver/
    http://spamlinks.net (see "Securing your System" and "proxies")
    http://www.fr2.cyberabuse.org/?page=abuse-proxy

    For more information on securing NAT firewalls/gateways, please see http://cbl.abuseat.org/nat.html

    I am not sure how to do this.

    Please help, Thanks
     
  3. mian

    mian Guest

    0
     
    set your hostname via the Plesk system area and you can also put the name in /var/qmail/control/me if you want to call your mailserver a different hostname than the main box such as mail.domain.com
     
  4. gameon

    gameon Guest

    0
     
    thanks for the info. I think we have fixed our problem. we changed the HOSTNAME in /etc/sysconfig/network from localhost.localdomain to a known domain name on the server. After restarting the server, we delisted from the cbl and thus far have remained off the list.

    I hope this helps.
     
  5. gameon

    gameon Guest

    0
     
    we were relisted on the cbl list once agian. This time we have changed the localhost.localdomain name in /var/qmail/control/me to the server domsin name. I hope this taked care of the problem
     
  6. JamesB

    JamesB Guest

    0
     
    Have you updated the hostname in Plesk under Server >> Preferences?

    If you update it there, it makes the necessary changes to qmail's me file and Apache's ServerName option.
     
  7. gameon

    gameon Guest

    0
     
    Thanks for the help. We have now changed localdomain.localhost to the server domain in the Server>Prefereneces as well. I wished we would have thought of that first!. Hopefully we will stay off the cbl list now..
     
  8. JamesB

    JamesB Guest

    0
     
    SSH into your system and telnet to localhost on port 25. You can see if qmail still reports localhost or the new hostname.
     
  9. chud67

    chud67 Guest

    0
     
    This is a real problem for me.
    I have checked in Plesk under Server - Preferences, and the hostname is entered correctly.
    I have also checked /etc/sysconfig/network and /var/qmail/control/me, and they both have the hostname of the server.

    However when I send email from Horde it delivers with a 'from' and 'reply-to' address of test@localhost instead of test@mydomain.com
     
  10. dbgrebey

    dbgrebey Guest

    0
     
    When you set the Full Hostname under Server Preferences it just needs to be: mydomain.com ?
     
  11. JamesB

    JamesB Guest

    0
     
    No.

    mydomain.com is your domain name.

    foo.mydomain.com would be a valid hostname.

    Read more: http://en.wikipedia.org/wiki/Hostname

    Once you've established a hostname, you need to make sure it resolves in DNS as well by accessing the Domains section in Plesk and creating a new "A record" that points your new hostname, foo.mydomain.com, to your servers primary IP address (typically the IP assigned to eth0 or venet0:0).
     
Loading...