1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail patch

Discussion in 'Plesk for Linux - 8.x and Older' started by bisiklet, May 17, 2006.

  1. bisiklet

    bisiklet Guest

    0
     
  2. freemind

    freemind Guest

    0
     
    I would like to know if you have confirmation about this question thx.
     
  3. bisiklet

    bisiklet Guest

    0
     
    No one replied. Still waiting. :(
     
  4. freemind

    freemind Guest

    0
     
    Ok so please someone in the support team answer to this question :) WE are still waiting.
     
  5. freemind

    freemind Guest

    0
     
    you tried this pack on 7.5.4 before?
     
  6. bisiklet

    bisiklet Guest

    0
     
    no i didnt
     
  7. rtwick

    rtwick Basic Pleskian

    23
     
    Joined:
    Nov 1, 2002
    Messages:
    33
    Likes Received:
    0
    this is for 7.5.4. can be used on 8.0 if you do not need SPF functionality
     
  8. bisiklet

    bisiklet Guest

    0
     
    firstly i am applying plesk patches later appliying qmail-quene path . when i try to compile having errors about open-ssl.
    how can i solve this problem ? if i dont apply ssl patch its compiling. i am trying to compile on RHEL 4 . thanx
     
  9. freemind

    freemind Guest

    0
     
  10. freemind

    freemind Guest

    0
     
  11. jean-david

    jean-david Guest

    0
     
    To avoid loosing time finding the order of patching:

    Code:
    cd QMAIL_BUILD_DIR
    patchDir=QMAIL_PATCH_DIR
    patches="
    $patchDir/patch-BC
    $patchDir/patch-TD
    $patchDir/patch-big-dns
    $patchDir/patch-chown
    $patchDir/patch-pb
    $patchDir/patch-pe
    $patchDir/patch-pf 
    $patchDir/patch-pg
    $patchDir/patch-ph
    $patchDir/patch-pi
    $patchDir/patch-pp
    $patchDir/patch-ps
    $patchDir/patch-pt
    $patchDir/patch-pu-tls
    $patchDir/patch-pv-smtp-auth
    $patchDir/patch-qmail-date-localtime
    $patchDir/patch-qmtpd
    $patchDir/patch-quota
    $patchDir/fr49-quota-patch
    $patchDir/patch-spf
    $patchDir/patch-z01-isoc
    $patchDir/patch-z02-libssl
    $patchDir/patch-z03-next-mx
    $patchDir/patch-z04-tcp-env
    $patchDir/patch-z10-spp
    $patchDir/patch-z15-smtpd-relay-reject
    "
    for p in $patches; do echo; echo $p; patch < $p; res=$?; if test $res -ne 0; then echo "ERRROR: patch $p"; break; fi; done
    
     
  12. zeeman

    zeeman Guest

    0
     
    Hi!

    I use will use the qmail in Plesk8

    I want to use the qmail-tap-patch.
    http://freshmeat.net/projects/qmailtap/

    I can patch a plain qmail-1.03 with this patch without problems.

    But I'm unable to build qmail.
    A vanilla qmail-1.03 compiles without problems, but the patched one doesn't:

    Code:
    auto-gid.c: In function 'main':
    auto-gid.c:21: warning: return type of 'main' is not 'int'
    ./load auto-gid substdio.a error.a str.a fs.a
    ( ./auto-uid auto_uida `head -1 conf-users` \
            &&./auto-uid auto_uidd `head -2 conf-users | tail -1` \
            &&./auto-uid auto_uidl `head -3 conf-users | tail -1` \
            &&./auto-uid auto_uido `head -4 conf-users | tail -1` \
            &&./auto-uid auto_uidp `head -5 conf-users | tail -1` \
            &&./auto-uid auto_uidq `head -6 conf-users | tail -1` \
            &&./auto-uid auto_uidr `head -7 conf-users | tail -1` \
            &&./auto-uid auto_uids `head -8 conf-users | tail -1` \
            &&./auto-gid auto_gidq `head -1 conf-groups` \
            &&./auto-gid auto_gidn `head -2 conf-groups | tail -1` \
            ) > auto_uids.c.tmp && mv auto_uids.c.tmp auto_uids.c
    make: *** [auto_uids.c] Error 100
    
    
    If a apply the qmail-tap-patch it fails at the same position (I have to modify the patch because some work was already done by another patch)

    Any hints?
     
  13. zeeman

    zeeman Guest

    0
     
    *push* and some new infos I found:

    The problem is caused by the "patch-pe"-patch.
    It adds the lines
    Code:
      char *uid;
      uid = argv[3];
      if (!uid) _exit(100);
    
    To auto-uid.c
    But the Makefile isn't patched so the Makefile calls ./auto-uid with only 2 arguments which result in the error 100.
     
  14. Effektor

    Effektor Guest

    0
     
    Hey PPL,

    I tried to compile the qmail-1.03 using the howto of meshier:

    http://meshier.com/2006/09/18/adding-greylisting-support-to-qmail-on-plesk-8

    I died anything till I got to the compilation.
    I used make, after the compilation was finished I
    got the first error. Caused by a wrong link in Makefile.

    Make tried to use /usr/lib/mysql/libmysqlclient.a instead of
    /usr/lib/libmysqlclient.a

    I fixed the link in the Makefile.

    At the end of the second try there where several errors because
    of "main" was no "int".

    First of all, mysql-devel and openssl-devel aren't available for Debian Sarge anymore. I install libmysqlclient12 and libmysqlclient12-dev instead of mysql-devel.

    Instead of openssl-devel I installed libssl-dev hope anything is right. Now I'm not shure if I should going on with the tutorial.

    Whats your oppinion of the error I talked about above?
     
  15. zeeman

    zeeman Guest

    0
     
  16. Effektor

    Effektor Guest

    0
     
    Thanks for ur fast reply, but it isn't realy helpfull.

    I just wanted to know if there are any further information on which
    debian packages to use instead of mysql-devel and openssl-devel to avoid the errors.

    Der Artikel auf deiner Seite ist für mich übrigens klar verständlich... :)
     
  17. zeeman

    zeeman Guest

    0
     
    the post wasn't about your problem.
    it was for the thread itself.

    your problem:
    the debian-packages are always called
    lib<name>-dev
    there are no -devel-packages around in the deb-resp.

    libssl-dev in debian is openssl-devel in suse
    libmysqlclient12-dev, too.

    the main-is-not-int-messages are warnings AFAIK.
    i saw them in my build, too.
    i doesn't care about them.
     
  18. dw604

    dw604 Guest

    0
     
Loading...