1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail reply to header and failure notices

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by yehudigt, Feb 15, 2011.

  1. yehudigt

    yehudigt Basic Pleskian

    19
     
    Joined:
    Feb 8, 2011
    Messages:
    35
    Likes Received:
    0
    I'm receving tons of failure notices due to an incorrect setting of return-path and reply to headers.
    Plesk 10.1.1 linux on centOs 5

    this is an example where you can see that return path automatically sets @ns220846.ovh.net which is the hostname.
    the same script was actually working fine on a cpanel server. This issue started as I transferred the domains on this new server.
    How can I fix this?

    Return-Path: <email@ns220846.ovh.net>
    Received: (qmail 12803 invoked by uid 502); 15 Feb 2011 00:39:17 +0100
    To: EasyFarma.it <mailto@gmail.com>
    Subject: [EasyFarma.it] Richiesta Informazioni Prodotto
    From: sender@gmail.com <sender name@ns220846.ovh.net>
    Reply-To: sender@gmail.com <sender name@ns220846.ovh.net>
    Date: Tue, 15 Feb 2011 00:39:17 +0100
    X-LibVersion: 3.3.2
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8; format=flowed
    Content-Transfer-Encoding: quoted-printable
    Message-ID: <20110214233917.5916.747024925.swift@www.easyfarma.it>
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,556
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Try to find reason of this problem in main Plesk maillog /usr/local/psa/var/log/maillog
     
  3. yehudigt

    yehudigt Basic Pleskian

    19
     
    Joined:
    Feb 8, 2011
    Messages:
    35
    Likes Received:
    0
    sincerely I took a look at the log, but wasn't able to fina anything about this issue.
    if you take a look at these two lines:

    From: sender@gmail.com <sender name@ns220846.ovh.net>
    Reply-To: sender@gmail.com <sender name@ns220846.ovh.net>
    the first part is ok "From: sender@gmail.com "
    but then it sets a strange address within the tag :<sender name@ns220846.ovh.net>

    the correct one should be:
    From: sender@gmail.com <sender@gmail.com>
    Reply-To: sender@gmail.com <sender@gmail.com>

    I think that this must be some setting of qmail
     
Loading...