1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail Stopped or not?

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by gwider, Jan 16, 2009.

  1. gwider

    gwider Guest

    0
     
    Hi Colleagues!

    I'm experiencing some strange behaviour with Qmail.

    It's working ;) (i.e. mails are being sent)

    But then our Nagios Monitor comlains about socket timeouts. And the Qmail service shows inactive on the services admin in Plesk, and won't start when I click on the green button.
    The Plesk Panel seems to have lost control over the service.
    Watchdog shows it as running.

    But how strange is that: One external system (our monitor) complains and one external system (mail client) doesn't see problems. And one internal system (Plesk Services) complains, while the other (Watchdog) doesn't detect anything?
    Any ideas?

    Most welcome! Thanks heaps!
    G
     
  2. gwider

    gwider Guest

    0
     
    One little addition: I've activated the Plesk Firewall module yesterday, but obviously the default SMTP rules are set to allow and "all other traffic" was set to 'deny'. But I've tried it with 'allow' as well. No difference to the weired service behavour.

    Do you think there is a connection?
    After all my mail client connects fine to Qmail.

    Thank you!
    G
     
  3. ziba@

    ziba@ Guest

    0
     
    Hello,

    Just double check that you can telnet to port 25 on localhost:
    # telnet localhost 25

    If it works then try disabling spf protection in mail services properties in Plesk. If this helps to solve problem with qmail shown stopped in Plesk services monitor then make sure that all dns servers listed in /etc/resolv.conf do work and do not have great delay on responses (if you see that a dns server responds slowly or does not respond at all then remove it from /etc/resolv.conf) - I have faced situation where due to long responses to spf queries qmail was shown stopped in Plesk
     
  4. gwider

    gwider Guest

    0
     
    Cool. You're a star.
    It seem the NS Blacklists where the problem, which caused Plesk to show the Qmail service as down.

    However the underlying problem was that, in deed, all entered nameservers were not responding. Entering a new one, external to the 1&1 network, solved the problem. I presume there must be some problems on their firewalls.

    Thanks for your help!
    German
     
Loading...