1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail strange failure

Discussion in 'Plesk for Linux - 8.x and Older' started by brianbatson, Mar 27, 2007.

  1. brianbatson

    brianbatson Guest

    0
     
    I am using PLESK 7.5 reloaded on a GoDaddy virtual dedicated server.

    I cannot access mail from outside or inside.

    I log on and execute telnet localhost 110 and get connection refused.

    I run netstat and sure 'nuff there isn't a process listening (or otherwise listed) on port 110 or 25.

    I do a ps command I can see that qmail-send is running.

    I look at the log /usr/local/psa/var/logs/maillog and I see:
    qmail status: local 0/10 remote 0/20
    (nothing is reported that looks like an error)

    I run /etc/init.d/qmail status and the report is qmail is stopped.

    So it looks like there are processes running but no-one is listening on 110 or 25.

    How can this be? Where should I look next?

    Help please and THANKS!
     
  2. servertune

    servertune Guest

    0
     
    Make sure Ports 110 and 25 are not blocked. You also need to make sure that your server resolves. Ask your host to check on the IPs in the /etc/resolv.conf file, /etc/hosts and other files. Did you check other log files for any errors including /var/log/messages.
     
  3. brianbatson

    brianbatson Guest

    0
     
    Thanks, but still stuck

    It is perhaps related to this.

    In the /var/log/messages file are lines like:

    (earlier in the file xinetd reported 8
    services - things seemed to be ok - then at 7:34 the following happened:

    Mar 27 07:34:59 ip-208-109-17-209 xinetd[32108]: service imap deactivated
    Mar 27 07:34:59 ip-208-109-17-209 xinetd[32108]: service imaps deactivated
    Mar 27 07:35:00 ip-208-109-17-209 xinetd[32108]: service pop3 deactivated

    and I look at /etc/xinetd.d directory and those three services have a zero length file. the pop3s service / file is still there.

    Perhaps I need to restore those three services? Where can I get the files that are supposed to be in /etc/xinetd.d ?

    mail them to my other (working :) email if you have them:

    bbatson@teleport.com

    and thanks bunches.
     
Loading...