1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Quotas and Traffic count not working

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by RodrigoM, Jul 1, 2009.

  1. RodrigoM

    RodrigoM Guest

    0
     
    Hello!

    I'm pretty new to the plesk admin world and I'm getting some troubles that are turning me crazy. I've searched through this forum, google several times but I just found nothing. Here are the description:

    Quotas and Traffic count are not working in plesk.

    System: Debian etch with user and group quotas activated in the /var partition.

    Symptoms: I've created a domain based on a preconfigured Domain Template. In this domain template "Overuse is not allowed" and I've stablished a Disk space Limit of 20 MB and a Traffic limit of 50MB (just for testing!). I've, also, selected "Physical hosting" with a hard disk quota of 20 MB (same as previous selected disk space limit). Theoretically, everything should be alright BUT!...

    - When I connect to the hosting via FTP (using FileZilla Client) and I transfer a file I get the first message that tells me something is wrong:

    Answer: 226-Transfer complete
    Answer: 226 Quotas off


    "Quotas off" =oS

    - Let's check the disk status for this domain in plesk: "Disk usage: 0 MB". ooops! Plesk didn't notice the uploaded file.

    - Let's check what Debian has to tell about this:

    # quota ecotur
    Disk quotas for user ecotur (uid 10001):
    Filesystem blocks quota limit grace files quota limit grace
    /dev/mapper/vg01-var
    6856 0 20480 156 0 0


    So, SO's quotas are working but plesk didn't notice that change.

    - Let's download the file and check the traffic for this domain in plesk: "Traffic: 0.00 MB/month". Plesk also didn't notice neither the upload nor the download transfer.

    OK, something is really not working. Let's restart the server. ... Nothing!. BUT after 24 hours the disk space was updated. =o|.

    May be is there any cron doing the job, but... which one?

    Yet another test: I deleted the file. The disk usage didn't changed. Should be 0 MB but it says 6.8 MB.

    Finally, the traffic still is 0.00 MB/month. It's curious because the AWstats reflects the traffic correctly.

    What's wrong with plesk? I'm completely lost. I don't know what to do.

    Perhaps the solution is creating a new cron executing that MAGIC script which updates the information BUT, what's the script?


    Could you, please, give me some advice or some light on this?

    Thank you so much.

    Rod.
     
Loading...