1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Remote MX fails for local system

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by evydaemon, Dec 14, 2009.

  1. evydaemon

    evydaemon Guest

    0
     
    Remote mail exchanger not working for local system through Plesk NS configuration.

    If you send an email from and to domains that are hosted on the system, mails that should be forwarded to a remote MX of the recepients domain get lost.

    eg:
    *office@domain.com wants to send to test@nasa.gov.
    *Both domains are hosted on the plesk server.
    *nasa.gov has an MX record: 212.12.1.1 which is a remote system somewhere.
    (serversomewhere.com IN MX mail.serversomewhere.com, mail.serversomewhere.com IN A 212.12.1.1) *nasa.gov has "Mail services" disabled in the Plesk Panel *mail from office@domain.com won't be passed over to 212.12.1.1 for some reason

    if "Mail services" is activated and the mailbox test@nasa.gov is active and the MX record is points to the local IP the mail will be delivered.

    Is there anything else to do if you want to get mails being sent to remote MX?

    A local dig shows the MX record correctly.


    Currently version 9.2.3 is installed
    fedora core 8
     
  2. RobOde

    RobOde New Pleskian

    22
    57%
    Joined:
    Dec 7, 2007
    Messages:
    12
    Likes Received:
    0
    Location:
    Norway
    Hello

    First, I hope the MX don't point to 212.12.1.1. A MX-record must point to a hostname, never an IP-address.

    This is up to the MTA and I can't see which one you use. If you use Qmail, check the file:
    /var/qmail/control/rcpthosts and verify that the domain is not in that list. It should be removed from there when you disable "Mail services".

    I'm not sure when Postfix keeps the list of local domain-names it should accept mail for, but try to find it and check the list there if you use postfix.

    Robert
     
  3. evydaemon

    evydaemon Guest

    0
     
    It's not in the rcpthosts file. we checked that earlier, also we are using postfix.
    the MX record is a domain name (mail.domain.tld), that points to the A record.

    Mails sent from local system to domains with foreign MX goes to the mail queue as defered.
    this shouldn't happen of course and unfortunately the server still thinks it should handle this mails.
     
  4. RobOde

    RobOde New Pleskian

    22
    57%
    Joined:
    Dec 7, 2007
    Messages:
    12
    Likes Received:
    0
    Location:
    Norway
    I'm sorry, but I'm not familiar with Postfix so I can't help you then. It sounds like everything should be okay, except that it don't work :)

    If I don't remember totally wrong Exim had its own file for local hostnames that where located remote. Domains needed to be in that file in order to get it to send the mail remote. Could Postfix have something similar?
     
Loading...