• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Roundcube- Http Error 500

M. Tolgahan ALAN

New Pleskian
Roundcube Error Log:
Code:
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_firebird' (tried: /opt/plesk/php/7.3/lib64/php/modules/pdo_firebird (/opt/plesk/php/7.3/lib64/php/modules/pdo_firebird: cannot open shared obj$
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_mysql' (tried: /opt/plesk/php/7.3/lib64/php/modules/pdo_mysql (/opt/plesk/php/7.3/lib64/php/modules/pdo_mysql: cannot open shared object file:$
PHP Warning:  Module 'sqlite3' already loaded in Unknown on line 0
PHP Warning:  Cannot load module 'pdo_pgsql' because required module 'pdo' is not loaded in Unknown on line 0
PHP Warning:  Cannot load module 'pdo_sqlite' because required module 'pdo' is not loaded in Unknown on line 0
PHP Warning:  session_start(): Failed to read session data: user (path: /var/lib/php/session) in /usr/share/psa-roundcube/program/lib/Roundcube/rcube_session.php on line 136
PHP Fatal error:  Uncaught Error: Class 'PDO' not found in /usr/share/psa-roundcube/program/lib/Roundcube/db/mysql.php:149

How to fixed ?
 
Check that these php modules are really loaded with

# /opt/plesk/php/7.3/bin/php -m

In directory /opt/plesk/php/7.3/etc/php.d/ you can find related ini files where loading these modules is specified.
 
Back
Top