1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

RPM reports 2 psa package

Discussion in 'Plesk for Linux - 8.x and Older' started by CBiLL, Aug 30, 2005.

  1. CBiLL

    CBiLL Guest

    0
     
    Running Fedora 1 and when I upgraded psa to 7.5.4 from 7.5.2 I had an package issue so I had to remove one the package "maildrop" to complete the upgrade.

    But why am I showing I still have 7.5.2 package install when after it upgraded to 7.5.4?

    here the query result


    # rpm -q psa
    psa-7.5.2-fc1.build75050128.10
    psa-7.5.4-fc1.build75050824.12



    Bill
     
  2. CBiLL

    CBiLL Guest

    0
     
    Now I find another strange thing.

    I went to the updater to see if there was something odd about two different package installed and it would never come up.

    Just sits at "Please wait. Loading ..."

    So now I can't get into my Plesk Updater at all anymore.


    I bet having those same package with different version must be locking up the updater but I have no idea how it came to this.


    Any way to fix this 2 package issue..

    I could remove the 7.5.2 but I am afraid that the 7.5.2 share the same files at the 7.5.4 that if I remove it, it will remove part of the 7.5.4 and bringing down PSA.




    How do i fix this issue or what do you recommand to correct this?

    Thank you
    Bill
     
  3. Cranky

    Cranky Guest

    0
     
    The upgrade most likely did not complete correctly. What does it say in /usr/local/psa/version? Does Plesk work for you with all the 7.5.4 changes, or is it still really just 7.5.2?
     
  4. CBiLL

    CBiLL Guest

    0
     
    /usr/local/psa/version says

    7.5.2 FedoraCore 1 75050204.16

    I can see the new spam assassin support and the new baya spam training in my Plesk also it installed another module called WatchDog in it too.


    Bill
     
  5. Cranky

    Cranky Guest

    0
     
    Check /tmp for your upgrade log. Do any errors show?
     
  6. CBiLL

    CBiLL Guest

    0
     
    Trying to check for quota support... done
    Trying to update component 'tomcat' in Components table... ERROR 1062 at line 1: Duplicate entry 'tomcat' for key 1

    ERROR while trying to update component 'tomcat' in Components table

    Aborting...



    i am not sure if that the first error which showed up then I asked about it in the forum so I tried the installer again and got an email saying upgrade was an success.



    I don't have tomcat install or I am not using it.


    BIll
     
  7. Cranky

    Cranky Guest

    0
     
    You need to remove the duplicate entry for 'tomcat' in the 'Components' table of 'psa' database then re-run psa installer with --force.
     
  8. CBiLL

    CBiLL Guest

    0
     
  9. CBiLL

    CBiLL Guest

    0
     
    So I just go into database and look for another entry called tomcat in componet table then delete the key 1?

    And how do I force the installer to run again since I always used the built in Plesk updater to update it?

    Thanks

    Bill
     
  10. CBiLL

    CBiLL Guest

    0
     
    I looked into the psa database and I see a

    tomcat not_installed

    tomcat4 not_installed


    so the tomcat4 is the dupicate that need to be deleted?


    Bill
     
  11. Cranky

    Cranky Guest

    0
     
    Via SSH run the following:

    mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

    This opens MySQL and connects you to the psa database. Then:

    select * from Components;

    This will show you everything in the Components table. You will see 2 entries for tomcat. One is probably tomcat, the other tomcat4. Then:

    delete from Components where name='tomcat';

    You can then re-run the Plesk update.
     
  12. CBiLL

    CBiLL Guest

    0
     
    I delete the tomcat and tomcat4 still in there .

    then I went to the updater and it still stucked in the Please wait, Loading loop.

    Any other suggestion to fix this?


    Thank you for your great help
    Bill
     
  13. Cranky

    Cranky Guest

    0
     
  14. CBiLL

    CBiLL Guest

    0
     
    Thank you for you help, I will go download it and try installing it .


    Bill
     
  15. CBiLL

    CBiLL Guest

    0
     
    One question.

    Since this is my first time I use a force rpm how long does it take to complete?


    It been almost 2 hours and my ssh screen is still showing

    [root@ns1 rpm_FedoraCore_1]# rpm -Uvh base/psa-*rpm --force
    (cursor here)

    but nothing more .. no output or anything else.


    Bill
     
  16. CBiLL

    CBiLL Guest

    0
     
    I rebooted the server and tried again .. Here what I got


    error: Failed dependencies:
    perl(Mail::SpamAssassin) is needed by (installed) psa-spamassassin-7.5.4-fc1.build75050824.12
    perl(Mail::SpamAssassin::ArchiveIterator) is needed by (installed) psa-spamassassin-7.5.4-fc1.build75050824.12
    perl(Mail::SpamAssassin::Message) is needed by (installed) psa-spamassassin-7.5.4-fc1.build75050824.12
    perl(Mail::SpamAssassin::perMsgLearner) is needed by (installed) psa-spamassassin-7.5.4-fc1.build75050824.12
    spamassassin >= 2.60 is needed by (installed) psa-spamassassin-7.5.4-fc1.build75050824.12






    I am sure those had to be installed already since it was working ever since untili this failed upgrade


    What I should do next?


    Thank you
    Bill
     
  17. CBiLL

    CBiLL Guest

    0
     
    I tried doing this to get around this issue.

    Removed psa-spamassassin and spamassain

    then tried installing Plesk 7.5.4 and everything seem to install fine this time.

    (that agreement notice scared me thinking I wiped everything back to clean psa install when I logged into Plesk but all still there .. PHEW .. )

    so I reinstall spamassassin and psa-spamassassin. No problems there and service started fine.

    I went into Plesk to set the spam assassin control in the main server panel and when I tried to save the setting, I got a pop up box saying "Cannot exec 'spamming start -c -C': Unable to start server."

    Bill
     
  18. CBiLL

    CBiLL Guest

    0
     
    I had to go back to Spamassassin 2.63 to get it working again.


    Look like it doesn't support Spamassassin 3 yet.



    Bill
     
  19. Cranky

    Cranky Guest

    0
     
    Sounds good. SA 3 is supposed to be supporteded, but I've not tested it yet so there may be problems.
     
Loading...