• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Selinux

ToolBox

Basic Pleskian
The plesk does need to be disabled selinux?

because i have a problem about fastcgi mode php session problem.
 
Plesk shipped with psa-selinux package. This package modifies the SELinux predefined policies configurations
to allow Plesk to perform its actions.
 
How to fix for session problem use with fastCGI mode

i have a session problem use with fastCGI mode.

error_log

mod_fcgid: stderr: PHP Warning: session_start(): open(/var/lib/php/session/sess_c78e27e94a5d4cc9135a11e0f176b62e, O_RDWR) failed: Permission denied (13) in /var/www/vhosts/domain.com/httpdocs/111128/lib/Pocket/class/Controller.php on line 210, referer: http://domain.com/111128/

no errors, if disabled selinux.
 
Usually this is caused by lack of permissions for session file. For example:

# grep ^session.save_path /etc/php.ini
session.save_path = "/var/lib/php/session"

Set session.save_path to /usr/tmp or /tmp and restart Apache. Alternatively change permissiongs for /var/lib/php/session:
# chmod 4777 /var/lib/php/session
 
chmod ok... but

# chmod 4777 /var/lib/php/session

php session works fine but,,,,,4777 is not default.

The degree of change likely to cause problems in the version of php.

The fundamental solution or not?
 
Back
Top