1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Sending Mail To External Mailserver

Discussion in 'Plesk for Windows - 8.x and Older' started by futec, Jul 22, 2004.

  1. futec

    futec Guest

    0
     
    Hi there,

    Situation:

    Our hosting server 10.0.0.1
    Our Ns1 and Ns2 10.0.0.2 and 10.0.0.3
    Mailserver 192.168.0.1

    Domain: test.com

    DNS Settings:

    mail.test.com. A 192.168.0.1
    pop3.test.com. A 192.168.0.1
    smtp.test.com. A 192.168.0.1
    test.com. A 10.0.0.1
    webmail.test.com. A 10.0.0.1
    ftp.test.com. CNAME test.com.
    www.test.com CNAME test.com.
    test.com. MX (10) mail.test.com.
    test.com. NS ns1.test.com.
    test.com. NS ns2.test.com.
    10.0.0.1 / 24 PTR test.com.

    User A send an e-mail from the domain test.com to user@test.com using a PHP script.

    Normally the server should look at the MX10 record and forward the e-mail to 192.168.0.1

    The server picks up the e-mail and thinks to itself: The domain test.com is a local domain so I am not forwarding anything and keeps the e-mail local, so user@test.com doesn't receive his e-mail!

    I always hosted on Linux working all fine, but it seems like Windows doesn't care about DNS?!

    Anyone has a solution?
     
  2. LithiuM

    LithiuM Guest

    0
     
    Did you try setting MX to 0 instead of 10.. ?
     
  3. chrisz7

    chrisz7 Guest

    0
     
    a late answer!

    I have just come accross this problem myself and after some searching made it work..

    To use an external mail server, set the MX records to point to your external mail server.

    i.e:
    mydomain.com MX (0) mail1.mymailserver.com
    mydomain.com MX (10) mail2.mymailserver.com

    this should work for all mail from sources other than your web server.

    To make sure all mail on your webserver goes to the right place open mailenable and go to:

    Messaging Manager\Post offices\mydomain.com\Domains and right click on the domain name. Activate "Act as smart host" and add the external mail server details into the box at the bottom.

    for more details on Smart Host view: http://www.mailenable.com/kb/Content/Article.asp?ID=me020010
     
Loading...