1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Serious Aliasing Bug

Discussion in 'Plesk for Linux - 8.x and Older' started by kwillmon, Aug 14, 2006.

  1. kwillmon

    kwillmon Guest

    I have the latest update to 8.1.1 and found out through search engines that content in my server's main domain can be accessed through the mail sub-domain for ALL other domains on my server. For example:

    can also be accessed by going to

    can also be accessed by going to

    Is anyone else having this problem too?
  2. michaellunsford

    michaellunsford Regular Pleskian

    Jul 25, 2005
    Likes Received:
    been that way for me since 7.x (my first soirée into plesk).

    I'm no expert here, but I believe it's that way so all the POP, SMTP, IMAP, etc, mail traffic gets forwarded to the right place on the server. The same is true of webmail (which you probably wouldn't notice because of the horde interface) and FTP.

    The "culprit" is the DNS settings under the server control panel. If your DNS skills are better than mine, then you might be able to figure out how to fix it.

    You might also be able to fix it by creating a "mail" subdomain on your default domain. Then adding in an index.php file that checks the $_SERVER['SERVER_NAME'] and does a header redirect to the www address of the same.
  3. crossconnect

    crossconnect Guest

    The reason is because the HTTP and SMTP services are accessible over the same IP address. If you set a default web site then any requests that don't match a valid web site (including the IP address itself, or in your case mail.domainname.com) will be answered by the default site.

    You could unconfigure the default site so that any invalid requests will be answered by the "Default Plesk Page", or you could manually set up a virtual host to respond to mail.* and fix it that way (but you'd have to do that manually and not through Plesk).

    It's not really a bug as such but it's more due to the nature of running virtual hosting.