1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

server for only web service, without mail

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by apsweb, Aug 31, 2012.

  1. apsweb

    apsweb Guest

    0
     
    hi,

    i have a linux server (CentOS) with plask 10.4.4, in this server i have configured some domain, for this domain i have the mail service in an other machine and all it's ok, but if i try to send an email to one of this domain the mail not exit from the server.

    for more explain:

    Server A (with plask 10.4.4 ) have domain internaldomain.com
    Server B is the MX configured for internaldomain.com

    if i try to send at info@internaldomain.com from my pc (or any other pc) all is ok
    if i try to send at info@internaldomain.com from Server A this not work
    if i try to send at info@externaldomain.com from Server A all is ok

    i try to configure by the plask the MX DNS, but not resolve.
    and in second place i try to disable DNS (i not need it) but not resolve.

    if i look with nslookup (by the shell of Server A) the MX configuretion it is correct, the MX is the Server B.

    what can i do for resolve the problem?
     
  2. Faris Raouf

    Faris Raouf Silver Pleskian Plesk Guru

    31
    30%
    Joined:
    Mar 15, 2009
    Messages:
    667
    Likes Received:
    17
    You need to switch email off for the domain. In Plesk, open the domain, click on Mail tab, click on Change Settings button, remove tick from "enable" box and click on OK.

    This is necessary because when qmail sees an email for a domain that exists in its control files, it will deliver the email locally no matter what the DNS says. If no mailbox exists, the message bounces.

    I'm not sure what the situation is if you have postfix installed instead of qmail.
     
Loading...