1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

server not reading vhost.conf?

Discussion in 'Plesk for Linux - 8.x and Older' started by michaellunsford, Jan 31, 2006.

  1. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    I've created a vhost.conf file inside the /home/httpd/vhosts/domain.com/conf directory to add a specific directory open_basedir line. Problem is, no matter what I do with the basedir line, I get the same error in PHP.

    open_basedir restriction in effect. File is not within the allowed path(s): (/home/httpd/vhosts/domain.com/httpdocs:/tmp)

    for fun, I even deleted the /tmp from the open_basedir line, yet it still appears in the error.

    To answer your first question, here is the current vhost.conf file:
    Code:
    <Directory /home/httpd/vhosts/domain.com/httpdocs>
    php_admin_flag engine on
    php_admin_value open_basedir /home/httpd/vhosts/domain.com/httpdocs/:/usr/local/images/:
    </Directory>
    also, I have restarted apache from the plesk control panel (there is no file called my_apci_rst in the /usr/local/psa/admin/bin/ directory).

    Help!
     
  2. poke

    poke Guest

    0
     
    php_admin_value open_basedir none

    Try this instead and restart apache....
     
  3. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    same error...

    not within the allowed path(s): (/home/httpd/vhosts/domain.com/httpdocs:/tmp)
     
  4. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    This will either clear something up or add to the confusion. I just changed my basedir restriction on another domain and restarted apache. phpinfo() reflects the change.

    copied the vhost.conf file from the known good domain to the problem domain. Changed the <directory tag to reflect the correct directory, and modified the basedir to also include the right stuff. phpinfo() still reflects the generic /domain/ directory AND /tmp/ even though, temp has been removed. It is still not showing the /usr/local/image folder I added.

    Is there a file somewhere that could be overriding the vhost.conf file, or a setting in plesk that is not allowing it to be read?
     
  5. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
Loading...