1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Service Management Question...

Discussion in 'Plesk for Linux - 8.x and Older' started by nhouse, Jul 7, 2005.

  1. nhouse

    nhouse Guest

    0
     
    Hello Everyone... I have a question about the state of my service indicators in the control panel. There is a link below to let you see a screen cap of what I am referring to. It seems to me like the SMTP service is sluggish. So, I looked at the service management area of the control panel and the little icons on the right seem to be different. They are all grayed out... even though a mouseover on the initial left icon says it is running. I may be wrong but I think those icons were on the right were lit up, so to speak, like the rest previously. Are your service restart / stop icons active in your Plesk?

    One footnote here... the only thing that I have changed recently was that I SSH'ed in with Putty and added the CPAN perl module and installed ImageMagick. I did both of these manually. This wouldn't have effected Qmail. would it?

    click here for the screen cap

    Thank You for your input.
     
  2. serve-you.net

    serve-you.net Guest

    0
     
    Using CPAN would not affect your RPM's (unless of course you install something that could overwrite them). Check that the qmail init script still exists (/etc/init.d/qmail). See what happens if you try to start/stop it. Does it work as it should? Can you send/recieve mail?
     
  3. nhouse

    nhouse Guest

    0
     
    Dan... thanks for the help. The service does seem to be working... but rather slowly. When I send something via Outlook, it seems to take too long to leave the outbox... well, at least compared to other email accounts I have used. It sits there for close to 5 seconds before it goes out.

    Does your Plesk Control panel look like mine... when you compare it to the screen cap I referenced?

    Also, how do you start or stop it from the command line. I am still pretty new to the command line stuff :confused:

    Thanks
     
  4. serve-you.net

    serve-you.net Guest

    0
     
    No, there is definitely something wrong with your install if the buttons are greyed out for qmail. Usually it means a package is not installed. For instance, mine is greyed out for drweb & tomcat, since I don't install them. check which packages are installed:

    rpm -qa | grep qmail

    Start/stop qmail:

    /etc/init.d/qmail stop
    /etc/init.d/qmail start
    or
    service qmail stop
    service qmail start

    Also, what OS/version of Plesk are you using?
    cat /usr/local/psa/version
     
  5. nhouse

    nhouse Guest

    0
     
    Dan... thanks again.

    1. On running the command to discover the installed packages, this was the output:
    psa-qmail-1.03-rh9.build75050506.13
    drweb-qmail-4.32-rh9.build75050506.13
    psa-qmail-rblsmtpd-0.70-rh9.build75050506.13

    2. The OS version and Plesk versions are:
    Linux 2.4.20-021stab022.11.777-enterprise
    psa v7.5.3_build75050607.13 os_RedHat 9
     
  6. serve-you.net

    serve-you.net Guest

    0
     
    Were you able to stop and start the qmail service? I'd also try restarting plesk itself afterwards, to see if there's any changes in the service management page.

    service psa stop
    service psa start
     
  7. nhouse

    nhouse Guest

    0
     
    Hi... yes I was able to start and stop [ok] so that "appears" to be working. When I logged in to Plesk, the gray icons were still there. This really concerns me because I need to move several domains and many, many email accounts to this virtual server... and I need to be confident that things will work smoothly.

    Another thought to share with you... I did run several updates just a few days ago. One of those updates was to the Plesk core itself. It wasn't a big jump though... 7.5.2 to 7.5.3 I think.

    Any more thoughts?

    ADDED: After looking at your reply, I started and stopped "qmail" from the command line... not PSA itself. I did reboot from the control panel though.
     
  8. serve-you.net

    serve-you.net Guest

    0
     
    I would just make sure that all of your PSA related packages are up to date. Check the updater and see if the autoinstaller says anythings out of date. Other than that, I'd say contact godaddy support. They seem to do some customizations, as the kernel that you are running does not match the OS.
     
  9. nhouse

    nhouse Guest

    0
     
    That bring a thought to mind... is there a command to run that will refresh the Plesk installation, so to speak? Maybe this would correct the problem?
     
  10. serve-you.net

    serve-you.net Guest

    0
     
    Login to Plesk as admin, go to SERVER->UPDATER click the link to your version. You should get a list of all of the available components, and whether they are installed and up to date.
     
  11. nhouse

    nhouse Guest

    0
     
    Oh... I'm sorry, I should have been clear on that. I have don thhat already and have updated everything that I could. The only things that will not update properly are two... specifically the VPN and Firewall modules. When I try, they say that they can't be updated with the current verion of Virtuozzo that I have. However, the Plesk core files and everything else did just fine.

    My previous question was about using a command line in SSH to refresh the files.
     
  12. serve-you.net

    serve-you.net Guest

    0
     
    You could try to force reinstall all of the rpm's from the tarball available from http://www.sw-soft.com/en/download/plesk75reloaded/

    Did you do the install of PSA, or was it already installed with the VPS? If it came installed, just contact godaddy and have them fix it our they can get swsoft to fix it. You don't want to break something further, that would require intervention later right ;)
     
  13. nhouse

    nhouse Guest

    0
     
    Yes indeed... this is a GoDaddy thing and I suppose I should be more patient. I just find their tech support too slow and I have the desire to do as much on my own as possible to be more familiar with it. I guess i'd better slow down a touch and let them look at it... I just need to get on with it, ya know.
     
  14. serve-you.net

    serve-you.net Guest

    0
     
    Don't get me wrong, I'm all for the do-it-yourself approach, but I'm also willing to accept the consequenses of my own actions. An sometimes it makes more sense to go with the if it aint broke dont fix it approach.

    Honestly, if the server isn't actually doing anything yet, i'd force an upgrade on it. Worst thing that could happen is it breaks, and you reimage it. One of the great things about having a VPS under virtuozzo, is you can do a reimage with the click of a button, and be back to the state you started at in no time.
     
  15. danweber

    danweber Guest

    0
     
    Was there ever any resolution to this problem?

    For quite a while now I can't control qmail from the Plesk control panel anymore. The icons are grayed out. I believe this happened with either the Virtuozzo update to 2.6.1 or the Plesk upgrade to 7.5.3, as it was working at the beginning of the year.

    Looking at the init scripts I can see that on a standalone Plesk installation qmail is running within the process space of the server, naturally, and the script will query the process id of qmail to determine if it is running or not.

    If running Plesk within Virtuozzo as VPS the qmail task is started outside ot the VPS process space. The init script checks to see if it runs within Virtuozzo and then determines if q-mail is running or not based on it listening on the appropriate port through a netstat query. There is no qmail task and no task id.

    I suspect that somewhere with one of the updated the control panel scripts got broken and now Plesk does not know about qmail anymore or how to determine its state.

    Anyone know why qmail has to run outsid e of the VPS as opposed to all the other tasks? Unfortunately the Plesk PHP files are encoded so I can't check what Plesk is looking for to populate the service status, anyone know?

    Thanks
    Dan
     
  16. uygarozan

    uygarozan Guest

    0
     
    qmail icons grays

    I have also problem with qmail. I had fresh plesk server and I just clicked on icon to stop qmail in Service Management area.
    Then all icons of qmail grayed uit. I couldun't start again.

    I read this forum and I tried command line with SSH: service qmail stop/start. It seems no problem.
    I tried:
    service psa stop/start,
    then I get:

    [root@ns1 root]# service psa start
    Reloading configuration: [ OK ]
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    /usr/local/psa/admin/bin/httpsdctl: line 227: 7211 Killed $HTTPD
    /usr/local/psa/admin/bin/httpsdctl start: httpd could not be started
    Starting Plesk: [FAILED]

    I tried:
    rpm -qa | grep qmail

    I get:

    [root@ns1 root]# rpm -qa | grep qmail
    tools-qmail-logging-1.0-1
    tools-qmail-autostart-1.1-1
    psa-qmail-rblsmtpd-0.70-rhel3.build75050506.13
    psa-qmail-1.03-rhel3.build75050506.13

    Also my Mailman Settings icon gray in Server area.
    Has anybody an advice?

    Thanks...
     
  17. nhouse

    nhouse Guest

    0
     
    Well... in my case, I was told that the Qmail icon being grayed out was because of an update to Plesk. I was also told that this should be fixed when the next update comes out (7.5.4 is out now). However, I could start / restart Qmail from the command line.

    About MailMan... it won't really work properly until you set it up in the ADMIN area of the server first... then it will function in the domains if you have given them permission to use it.

    Hope this helps a little.
     
  18. uygarozan

    uygarozan Guest

    0
     
    thanks

    Thank you very much voor the answer.

    Anyway, I'll wait update (7.5.4) then.

    In "Server Administration" area I couldn't find to icon to set up Mailman. :(

    Which icon is that?

    (In "server Preferences" mailinglist enabeld.)

    Thanks again and greetings..
     
  19. nhouse

    nhouse Guest

    0
     
    I can't remember the icon exactly, when it is setup, it goes away. I think it may have said something like "Mailing List Administration" or something like that.
     
  20. uygarozan

    uygarozan Guest

    0
     
    thanks

    Thanks a lot for the replay...

    I have still no solution. I searched everywhere.. but found nothing...

    In another forum say men:

    "You can find Mailman mailing lists for each domain in 'Mail', it is 'the other' tab."

    But there was also nothing. May be this problem is connected with qmail problem.

    Anyway I'll go on to search another forums.

    Greetings..

    uygarozan
     
Loading...