1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Service Unavailable errors

Discussion in 'Plesk for Windows - 8.x and Older' started by jameszarr, Jul 18, 2005.

  1. jameszarr

    jameszarr Guest

    0
     
    Hi Guys

    I have a windows 2003 standard edition with plesk 7.5 installed, I always had problems with the web sites at random (no particular web site) all of a sudden showing "Service Unavaliable" finally after lots of reading and research I found out that this is due to Application pool for that site being down

    This is the error I get in the error log:

    Event Type: Error
    Event Source: W3SVC
    Event Category: None
    Event ID: 1002
    Date: 7/18/2005
    Time: 12:37:54 AM
    User: N/A
    Computer: PLESK1
    Description:
    Application pool 'lyroschen.com(pool)' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    So since I did not find any solution to this after months of research, I turned to EV1 support for help, they told me to turn off the Rapid-Fail protection in the application pool area, which I did. And indeed that fixed that problem, however, now I have a new issue, again at random time now the PHP pages stop responding and giving me and the clients this error:

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.


    Now the strange thing is that this error appears on all the sites on the server, so no one can run the PHP pages, as if the whole php engine was down, But Plesk control panel runs just fine, and it uses the same php parser but it uses a different webserver.

    This will keep going for about 15-20 minutes and then it clears up by itself, there are no error logs for this. I have applied all hot fixes from microsoft even one for the multiprocessor errors of getting "Service Unavailable"

    Did anyone else have this problem?

    Thanks in advance for any help you can give me on this issue.
     
  2. jaytee

    jaytee Guest

    0
     
    Here's a snippet that might be helpful in your situation:

     
  3. cybernova

    cybernova Guest

    0
     
  4. hellfish

    hellfish Guest

    0
     
    I have almost the same problem as jameszarr with 3 websites.


    we just installed php5 on our server and after a while when we typed the address into the browser the websites keept loading and loadin and never stoped (although nothing was shown other than a blank page).

    The solution we found for this was to create an application pool for each website and this worked except for 3 websites that always got the application pool stoped thus getting the Service Unavailable message.

    We are still trying to figure out what to do.

    why would these websites have problems? one of them is almost intirelly made in html, it only has 3 php forms to send an e-mail.
     
  5. cybernova

    cybernova Guest

    0
     
    make sure u add the iusr's of those domiains to the IIS_WPG group....if it still does nt work , switch the application pool user to network service ....this should work
     
  6. hellfish

    hellfish Guest

    0
     
    thank you for the answer but that didn't do the trick, it still doesn't work :/

    any more ideas?
     
  7. cybernova

    cybernova Guest

    0
     
    change the application pool to networ service .....it should work
     
  8. zubin

    zubin Guest

    0
     
    didn't help ...
     
  9. zubin

    zubin Guest

    0
     
    did this help?

    edit: no it didn't ..
     
  10. cybernova

    cybernova Guest

    0
     
    If you are using plesk 7.0.3......upgade it to 7.5.4 ..the issue is fixed in the new version
     
  11. Ninova

    Ninova Guest

    0
     
    also you can repair it with reinstall plesk...

    dont uninstall only reinstall on it...
     
Loading...