1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Service Unavailable Problem

Discussion in 'Plesk for Windows - 8.x and Older' started by Matador, Sep 9, 2004.

  1. Matador

    Matador Guest

    0
     
    Hi Friends,

    Just got Plesk 7.01. The box is Windows 2003. I was using PLESK 6.5.2 and just transferred to this new version. I started to get this boring message, "Service Unavailable" when I tried to reach some domains. What does that mean? I guess its related with the hard disk quota of any reseller accounts or domains. Any ideas?:confused:
     
  2. Matador

    Matador Guest

    0
     
    Any Suggestion? nobody faced that problem? :confused: :(
     
  3. addstravel

    addstravel Guest

    0
     
    I had the same problem.

    Re-starting IIS fixed temporarily but happened again.
     
  4. WebCTRL

    WebCTRL Guest

    0
     
    Had this happened and this is what I did:

    Open Administrative Tools->Event Viewer and if you see the following W3SVC-WP (IIS6) error messages:

    - Could not load all ISAPI filters for site/service. Therefore startup aborted
    or
    - The HTTP Filter DLL C:\WINDOWS\System32\RpcProxy\RpcProxy.dll failed to load. The data is the error.


    Remove filter from IIS manager: (Web Sites->Properties->ISAPI filters plus disable that filter in Web Server Extentions).
    Restart IIS completed OK.

    Go back to the log and to see if the following errors in system event log appear:

    The identity of application pool 'domain.com(pool)' is invalid,
    the World Wide Web Publishing Service can not create a worker process to serve the application pool. Therefore, the application pool has been disabled. ( this is why you get "service unavailable")

    - A failure was encountered while launching the process serving application pool 'domain.com(pool)'. The application pool has been disabled.

    Just reset password for user IUSR_xxxxxx that identifies the
    application pool for domain 'domain.com in Computer Management console, set the same values for identities of Web Sites->domain.com and Application Pools->domain.com(pool).

    re-start the application poot for the domain.com and it should now opens without errors.

    This what tech support said to do....and it is working. However they do not know why it happened in the first place....
     
  5. jahsh420

    jahsh420 Guest

    0
     
    This worked perfectly, thanks very much for the detailed instructions. I really appreciate it!!
     
  6. alldirections

    alldirections Guest

    0
     
    I had the same problem and it was fixed in minutes.
    Thank you for your detailed explanation.

    Marcel
     
  7. hostia

    hostia Guest

    0
     
    i had the same problems a while ago. Turned out that Plesk hadn't given ASPNET any permissions for the httpdocs folder. Once i fixed that, it worked.
     
  8. abcinternet

    abcinternet Guest

    0
     
    no luck here

    i tried everything you said, but looks like im not one of the lucky ones.

    it still says "service unavailable" for me.

    any other tips?
     
  9. abcinternet

    abcinternet Guest

    0
     
    Actually, now it just says "web site found. waiting for reply..." and doesnt go further.
    I'm not using any scripting. Just the default html file.

    EDIT: and now back to "Service Unavailable".

    Its something to do with the application pool. just cant figure out what!
     
  10. zubin

    zubin Guest

    0
     
    were u able to resolve that issue ? insufficient permissions to the ASPNET user tend to cause that.
     
  11. websahibi

    websahibi Guest

    0
     
    2 Solutions

    We are using this solution for Plesk 7.02

    If you're using 7.03 you have no way but if u're using 7.01 or 7.02 it works..

    Go to IIS Manager

    On the "Web Sites" right click, Properties
    On the service tab select "Run WWW service in IIS 5.0 isolation mode"

    it will take some time..

    After the service comes back, select the web site that gives the error. Right Click Properties

    On the home directory tab select "High (isolated)" for application protection.

    Please do not try this for 7.03 version of plesk because if you do plesk will not create web sites..

    This is the solution. We're hosting 1700 web sites in a P4 3.0 with 1 GB of ram very good with this config...
     
  12. mdisher

    mdisher Guest

    0
     
    We had the same problem here. The solution ended up being to enable w3 worker processes under a shared desktop. This was set on install but did not get setup in the registry. This is directly off of MS KB831135:

    1. Click Start, click Run, type regedit, and then click OK.

    2. Locate the following registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC

    3. Right-click Parameters, point to New, and then click DWORD Value.

    4. Type UseSharedWPDesktop.

    5. Set the value for this new key to 1.

    6. Quit Registry Editor, and then restart IIS.
     
  13. cybernova

    cybernova Guest

    0
     
    Does this fix the php...CGI HEADERS ..issue ?
     
  14. Adam Walsh

    Adam Walsh Guest

    0
     
Loading...