1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Session Save Path unwriteable

Discussion in 'Plesk for Linux - 8.x and Older' started by sabanir, Jul 9, 2006.

  1. sabanir

    sabanir Guest

    0
     
    I am installing Joomla/Mambo on a domain I have running on my server. I have configured the permissions of the files correctly but I keep getting a warning saying that the session save pathe is unwriteable
    /var/lib/php/session
    when I navigate to this in ftp and try to change the permissions it will not let me do this. I have gone all through plesk trying to figure out how to get this to work...PLEEEEEEASE help me! I am under deadline and I don't know where else to turn.
     
  2. ZX81Pro

    ZX81Pro Guest

    0
     
    Hi,

    vi /etc/php.ini

    Replace : session.save_path = /var/lib/php/session
    By : session.save_path = /tmp

    :)

    ZX81Pro
     
  3. sabanir

    sabanir Guest

    0
     
    Thank you for that. I assumed that you meant for me to ssh in? I did that and it worked like a charm.

    Thanks again!
     
  4. ZX81Pro

    ZX81Pro Guest

    0
     
    Yes, with ssh of course.
    To be sure copy the file to php.ini.bak01
    Then vi /etc/php.ini
    I assume you know vi !

    :)
     
  5. networxstudios

    networxstudios Guest

    0
     
    Hi,
    I have changed to /tmp now, but Joomla still reports this dir to be "Unwritable" when I check system information.

    I cannot install anything in this Joomla-installation, I guess this is becouse of the session-directory?

    Regards,
    Kurt
    Norway
     
  6. jahsh420

    jahsh420 Guest

    0
     
    Make sure you restart apache after you make any changes to your php.ini
    /etc/init.d/httpd restart
     
  7. networxstudios

    networxstudios Guest

    0
     
    yeah, I have restarted apache as well. I used httpd -k stop and then -k start.

    Still no go...

    Kurt
     
  8. jahsh420

    jahsh420 Guest

    0
     
    Make sure safe_mode is disabled in your php.ini or for the site. Also, what are the permissions on your /tmp directory:
    ls -la /tmp
     
  9. networxstudios

    networxstudios Guest

    0
     
    drwxrwxrwt 5 root root 4096 Aug 2 15:28 .
    drwxr-xr-x 23 root root 4096 Jul 23 17:38 ..

    Regards,
    Kurt
     
  10. networxstudios

    networxstudios Guest

    0
     
    safe mode in /etc/php.ini is also off

    Regards,
    Kurt
     
  11. jahsh420

    jahsh420 Guest

    0
     
    I am out of ideas then. Did you get the same error when you use the session path of /var/lib/php/session? You can try it back to this and run chmod 777 /var/lib/php/session to see if this helps.
     
  12. hansf

    hansf Guest

    0
     
    Had the same problem. Plesk 8.0 w. Joomla 1.0.10 and this thread helped me quite a bit. The file to edit is not /etc/php.ini though but /etc/php5/apache2/php.ini. This worked for me at least.
     
  13. jwdick

    jwdick Guest

    0
     
    You can also change it on a per domain basis if you prefer by entering :

    php_admin_value session.save_path "new path here"

    in the vhost.conf file
     
  14. networxstudios

    networxstudios Guest

    0
     
    I cannot find that path on my just recently installed Plesk 8 for Linux...any advise?

    Regards,
    Kurt
     
  15. ZX81Pro

    ZX81Pro Guest

    0
     
    Try in ssh as root :
    find / -name php.ini -print

    (you have to wait a lot)

    For me (Plesk 8.0.0) it is (I say again) :
    /etc/php.ini
     
  16. Wim Van Roy

    Wim Van Roy Guest

    0
     
    Hello,

    Is it only me that doesn't understand anything from this here?

    Could somebody translate it in a more newbie frendly post ;-)
     
  17. lordbarron

    lordbarron Guest

    0
     
    Hi Wim Van Roy -
    yes this is all pretty daunting. I myself strugle with all this. But basicaly, I asume your isntalling some php software and this 'session save path' is flagging up. Firstly it is quite important that you get this to work on most web applications.

    Basically the system needs to know where is can save session info. This is set by the php.ini file.
    You can only access this file if you are runnning a dedicated or virtual private server, if your on shared hosting you need to ask your web host (who will most likely say no way!- they did to me).
    Right so I am now assuming you have a server which runs on Linux (linux being an operating system like windows, but popular for web servers).
    If you have a vps or dedicated server you will be able to access the 'terminal' (dos prompt) via SHH or SFTP (which is an ftp gui based version of SSH). If your on windows at home you can use FileZilla, if your on a Mac I think CyberDucky has SFTP.

    To actually edit the php.ini you will need to log-in via the root user. So find the ip address of your server, use that as the ftp address, your user name will be root and the password is whatever root's password is, see you account details for that one.

    Now use that in file zilla, log in and navigate all the way to the root directory (unless you know where ur php.ini file is). Theres often multiple directorys called php.ini just look arond for them. Mine is in 'etc' yours might be in /usr/local/lib/php/ .

    In a SSH terminal you can type in whereis php or there are various other commands that will let you find the file or names which include what you typed in. To use SSH you will need a terminal (if you have a web control panel often there is a web based terminal in those, i know plesk uses a java terminal which works ok).

    Right so anyways, you've found your php.ini file in your sftp now drag and drop it onto ur desk top, rename it to backup (seriously do this) and then make another copy. Then from there make any changes you've been instructed and reupload it and reboot the server (see below).

    If you still get the red flag, check the php.ini file has the right permissions. To do this locate the php.ini file again (should be easier this time) and right click on it and in filezilla click set permissions. Just remember what number it displays (write it down) and overwrite that number with 777.

    now restart your server to do this I use plesk to reboot the whole thing, but you can also do this through the terminal (search for a linux command to exit/reboot, sometimes exit works, depending on the version/distro).

    Now refresh the page you were getting the red flag, and hey presto it should work. obviously theres plenty of blanks in my explination but you can google those pretty easy.
     
  18. kleinbaas

    kleinbaas Guest

    0
     
    Fixed!:

    This fixed this problem for me: create a tmp folder in C:\ on the server (not in the joomal or web root)
    courtesy of www.brightvisions.co.uk
    Other details to consider:
    I first added the save_path line in php.ini as mentioned EVERYWHERE
    I am using a windows xp box as a web server with apache, php and mysql
    Good luck and have patience young padawans
     
Loading...