1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Setting Up SMTP Relay

Discussion in 'Plesk for Linux - 8.x and Older' started by novice610, Dec 1, 2005.

  1. novice610

    novice610 Guest

    0
     
    Good Morning, Folks,

    I'm no expert or intermediate for that matter, but everyone else sounds well read on this software, so I hope you could help! I recently migrated my domain to a virtual dedicated server powered by Plesk 7.5.3 Reloaded. I have set up e-mail accounts through Plesk, but they aren't working because I need to set up an SMTP relay (I think). The virtual server was purchased through GoDaddy, but they can offer no help because they're a reseller, which led me to this site. My tech person is stumped and I need to get these e-mails up and running like yesterday. I have the name of what the server should be, but I have no idea what to do with it. The error message I get when I try to send Webmail is: "There was an error sending your message: unable to connect to smtp server localhost:25" and the relay server is k2smtpout.secureserver.net. If any of you would be nice enough to walk me through it, I'd appreciate it. Like I said, I'm not a wiz, but if you can give me clear instructions, I can take it from there. Thanks! :)
     
  2. Lagman

    Lagman Guest

    0
     
    I don't have an answer for you but I have a little more information because I'm in the same situation as you are.
    When I contacted their support team, the rep informed me that this problem was due to the fact that there was no email service installed on my virtual dedicated server. I logged in to the plesk administrator and confirmed that qmail wasn't installed. He told me that this was the typical setup and that if I wanted my own email server I was authorized to install any mail server I wanted. He also indicated that I could find out how to do that by doing a google search. The only other option he mentioned was that I could use their relay server but I would have to buy that email service as an additional package.
    I looked in to this and it is possible but it would require an additional setup for each email user which defeats the purpose of having a plesk control panel for my domain users to setup their own email accounts.
    It seems like an incomplete setup, particularly when you can setup the email account in plesk administrator for an email account that has no way of working. I'm sure this problem is exclusive to godaddy virtual dedicated servers or their dedicated servers.
    I will continue to search this board to see how others may have resolved this problem. If anyone knows of a thread that covers this topic please post it here. Thanks.
     
  3. novice610

    novice610 Guest

    0
     
    Re: STMP Relay Mystery (Unreal!)

    Lagman,

    Thanks for the very useful information. You seem to have gotten a lot further along than I did w/ customer service. I'm really floored that the package would be, as you say, "incomplete." But it makes perfect sense now. I'll keep you posted if I make any headway with this new information and I hope you will do the same. Again, thanks a million!
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    GoDaddy (supposedly) sets up all servers with the mail relay in place (/var/qmail/control/smtproutes) which should already
    contain the : k2smtpout.secureserver.net entry (notice the colon). I believe this to be part of their anti-spam method, if nothing else, all outgoing emails from all servers can be logged on their end and tracking down spam sources would be a bit easier than searching through 1000's of server's/domain's log files...

    If their policy is to install Plesk, but not the default Qmail package, then that is just not right. Their statement to you "I was authorized to install any mail server I wanted" is not totally correct. Plesk uses Qmail by default. If you wanted to use some other email server package, you would have quite a chore to tackle.

    To see if you do have Qmail installed, from a shell prompt:

    rpm -qa |grep 'qmail'

    should return at least 2 packages:
     
  5. Lagman

    Lagman Guest

    0
     
    Shadowman,

    Thank you very much for your post. I was able to confirm the things you mentioned. I did cat /var/qmail/control/smtproutes which did contain the :k2smtpout.secureserver.net entry.

    I also did rpm -qa |grep 'qmail' which came up:
    psa-qmail-rblsmtpd-0.70-fc2.build75050506.13
    psa-qmail-1.03-fc2.build75050506.13

    So if that indicates the proper files are installed, then novice610 and I may be looking at a configuration or setup bug?

    I've tried to telnet to port 25 and get nothing, and I've created a mail user and confirmed that I can't send or receive mail through that account. I also carefully copied all those details in to a message and generated a new support ticket in hopes that what the telephone tech was wrong in what he told me. When I get that response I'll post it here.

    Shadoman, can you recommend some commands I can run to insure my qmail service is running? Under Plesk, the buttons are greyed out.
     
  6. ShadowMan@

    ShadowMan@ Guest

    0
     
    ps -ax |grep 'qmail'

    telnet localhost 25 (from the server's shell prompt)

    netstat -an |grep ':25'

    telnet ip.add.re.ss 25 (from outside the server)
     
  7. Lagman

    Lagman Guest

    0
     
    Resolved by godaddy

    Thanks to ShadoMan for all your help.
    Good luck to novice610. I hope this helps.

    It appears that the level one voice tech I got was wrong.
    I generated a support ticket with godaddy and they wrote me back. In addition to giving them examples of the various things I had tried and the resulting error messages, I sumarized by stating that email was not functioning on my new virtual dedicated server. Here's the reply:

    Dear Lagman,

    Thank you for contacting Customer Support.

    We have examined your server and restored its email operability at its time. We sent a test email after creating a test email account on your domain and was able to send out mail successfully via webmail. We recommend that you check your server and mail logs to determine exactly what the cause of this error was.

    Please let us know if we can help you in any other way.

    Sincerely,

    Bo P.
    GoDaddy.com
    Customer Service Representative

    So there you have it. I've now tested various send and receives with various accounts using POP3, IMAP and will now go in to tweak with my settings now that this works as expected.

    I suppose it's understandable that they could have had a setup malfunction when they created my server but it's unusual that another user would have the same exact problem as I do. I'm also slightly frustrated with godaddy for leading me in the wrong direction when the phone tech indicated that I didn't have a mail server and that I should set up my own. I'm glad ShadoMan got us on the right track though. And it does make sense now that I wasn't able to find much information on this problem. I'd suspect that if it was policy of godaddy to build VPS with no email support people would be shouting that from the roof tops.

    Now I'm going to go learn how to find those logs they mentioned and see what I can figure out.
     
  8. ShadowMan@

    ShadowMan@ Guest

    0
     
    /var/log/messages
    /var/log/secure
    /usr/local/psa/var/log/maillog

    Those are the 3 standard files to check. And of course, they didn't bother to explain what *exactly* they had to do to "restore functionality".... it would be nice to know, posted here for other GoDaddy clients in the same situation....
     
  9. karlsworld

    karlsworld Guest

    0
     
    Yes, such as myself! I'm having the exact same problem with a new server form godaddy. When I finally get it fixed I'll post it here. Hopefully someone will beat me to it.
     
  10. VIB-host

    VIB-host Guest

    0
     
    Simular question...

    My Plessk doesn't log the mail traffic :(

    How do I make it do so, I would really like to be able to se whats going on on the mail traffic, and what e-mail accounts there are send mail to, so I can set up a spamtrap
     
  11. Evanstaul

    Evanstaul Guest

    0
     
    I am having troubles with GoDaddy too. I just bought a dedicated server, and right away I can't send emails out, but can send emails to domains within. Their support won't help with this, they said I was defaulted to safe mode, but in php.ini my safe mode is OFF. Does anyone have a solution to this?
     
  12. jcoulter

    jcoulter Guest

    0
     
    I'm not an expert with Plesk my any means, but here's a couple of ideas.

    #1 - Go to Server -> Mail and make sure Relaying is not "closed". If SMTP is checked, make sure the user sending the email has in their email program account setup the field checked for Outgoing Mail Server requires authentication.

    #2 - Go to Server -> Service Management and make sure the SMTP service is listed and running.
     
  13. propmaster

    propmaster Guest

    0
     
    I too have a server from Go Daddy. I am suprised that no one has posted a solution to this problem yet! I have submitted a ticket to Plesk Support and if they reply with a soulution, I will post it here for everyone. I am really aggervated with Go Dadddy for I feel they lead me to believe that everything was set and ready to start adding domains to. You would think that with as many people as there are in the same situation as I am in that either Plesk or Go Daddy would have a simple easy to follow solution for this problem!!
     
  14. Lagman

    Lagman Guest

    0
     
    Though godaddy never told us exactly what caused the problem or how they fixed it, a trouble ticket to godaddy support eventually corrected the problem in my case as mentioned above.

    I called them and got mis-directed. I came to this board and considered a ticket to plesk but figured the problem was with the godaddy setup, not the makers of plesk. I posted a carefully worded ticket to godaddy and in a about a day they fixed the problem. Thier brief message is copied above in one of my posts.

    I suspect that there may be some issue that is causing this in some, not all, of the new v-server setups at godaddy and that the problem may be worsened by the fact that their phone support reps are like most, reading off a script and don't actually know how to get in the server and look at stuff, troubleshoot it, and fix it like the techs they have responding to the tickets.

    I too was quite frustrated but once they fixed it I've been very happy with the server performance and service. I host multiple BF2 servers, teamspeak, ventrilo, shoutcast, sql and around a dozen domains with ease. Good luck to you and have fun.
     
  15. chitchatonline

    chitchatonline Guest

    0
     
    after reading this post i realize going with godaddy was not the best idea since i have NO IDEA how to use telnet or ssh or highend stuff...

    i'm a web designer... not a technical guru on fixing problems in the backend..

    and i just can't get my mail to work.. i keep getting the same error as here...

    but reading your posts make no sense to me cause i just don't inderstand the lingo very well...


    i called godaddy... they keep saying it's your machine and you are responsible for everything...

    i feel like pulling my pants down and beding over for godaddy with my checkbook...

    it's sad how a company this big would mess around like this... do they think that majority of the people know how to work their account??? :mad:

    i bought two servers with godaddy without knowing that i would have hard time...

    lol you live and learn i guess
     
Loading...