1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Site Preview -> You are not authorized to view this page

Discussion in 'Plesk for Windows - 8.x and Older' started by HendrikM, Apr 8, 2005.

  1. HendrikM

    HendrikM Guest

    0
     
    When clicking on "Site Preview" under a Domain the following appears in my browser:

    With Internet Explorer as browser:
    1. An login popup window appears.
    2. I fill in the FTP/Frontpage Credentials
    3. I Receive an Error:
    With a Mozilla type browser no popup appears and I receive the following immediately:
    Please help!
     
  2. renhack

    renhack Guest

    0
     
    You can usually correct this by changing your password to something else. You can then change it back to your original password if you want. It will reset the permissions.

    -r
     
  3. HendrikM

    HendrikM Guest

    0
     
    Nope... I changed the FTP/Frontpage password, but to no avail...

    Could it be Windows 2003 SP1 which might be causing this?
     
  4. MarcoKraak

    MarcoKraak Guest

    0
     
    same problem here,

    Greetings,

    Marco
     
  5. swarm

    swarm Guest

    0
     
    Such problems usually appears if permissions on files in httpdocs folders missed or password for IUSR_mydomain user in IIS security doesn't match password for that user in system.
     
  6. MarcoKraak

    MarcoKraak Guest

    0
     
    Solution found... In IIS change IUser for problemsites to IUSR_SERVERNAME. So if servername is myserver change user for anon access to IUSR_MYSERVER.
    This works for me.

    Greetings

    Marco
     
  7. shortcut

    shortcut Guest

    0
     
    Beauty.. Works a treat for me.. :)

    I did this by..

    Logging into IIS, Right Clicking on the site in IIS, click properties.

    Left click Direcotry Security, click EDIT under Authentication and access control.

    ENABLE ANONYMOUS ACCESS should be ticked.

    INTEGRATED WINDOWS AUTHENTICTION should be ticked.


    Update the password to be the same as the FTP password for this account in plesk.

    Username should look like this

    IUSR_ftpusername

    Click OK

    Click APPLY

    Refresh the site.

    and it should work.
     
  8. Hilco

    Hilco Guest

    0
     
    I encounter this same problem using Plesk 7 combined with Windows 2003 SE.

    Wish this would be fixed in Plesk cause it;s pretty annoying.
     
  9. shortcut

    shortcut Guest

    0
     
    Actually, they have.

    This seems to only affect Plesk 7.5.4, BUT, There has been a hotfix released for Plesk 7.5.4 for windows which fixes two major issues, as well as many other minor issues.

    #1 The plesk key keeps rolling back to default,

    #2 When changing FTP passwords, the website will require the anonymous web user to provide a password.

    Both of these issues havebeen fixed inthe following hotfix:

    <A href="http://download1.sw-soft.com/Plesk/Autoupdate/plesk7.5.4_update051003.15.msp">http://download1.sw-soft.com/Plesk/Autoupdate/plesk7.5.4_update051003.15.msp</A>


    <A href="http://download1.sw-soft.com/Plesk/Autoupdate/plesk7.5.4_update051003.15.txt"> http://download1.sw-soft.com/Plesk/Autoupdate/plesk7.5.4_update051003.15.txt</A>

    Best regards,
    Sean.
     
  10. mikelegg

    mikelegg Guest

    0
     
    Hot Fix? Hot Nothing!

    I used to be able to fix this problem by resetting the IUSR_domain password in IIS.

    I ran the hot fixes above and not only did it NOT fix the problem, I can no longer manually fix it by resetting the password.
     
  11. shortcut

    shortcut Guest

    0
     
    Hrrm, many sites or only one?

    Gotta make sure that the username is

    IUSR_ftpusername


    and make sure the ftpusername hasnt been changed within plesk.

    A reboot might also be needed. On all the servers ive worked with this specific problem, the hotfix sorted it out on all of them.

    The other option is to DISABLE anonymous user access in IIS

    then reset the password within plesk, and plesk will automagically re-enable the anonymous user and write in both the correct username and password.

    Best regards,
    Sean
     
  12. shortcut

    shortcut Guest

    0
     
    Plesk 7.5.5 and 7.5.6 are out now too.
     
  13. mikelegg

    mikelegg Guest

    0
     
    I'm dealing with just one site at the moment but this occurs for about half of the new sites that my clients create.

    I tried disabling anonymous user access in IIS, and then resetting the FTP password (and the domain user password just to be sure) in Plesk, but it didn't automagically re-enable the anonymous user or write in the correct username and password.

    I've manually re-enabled anonymous user access in IIS and
    now I'm prompted for a username and password even when I use the domain name. (as well as when I use Site Preview).

    A reboot may help, (that's the cure-all for windows isn't it?) I'll try it after business hours and see if it helps.
     
  14. mikelegg

    mikelegg Guest

    0
     
    Well, I did the reboot and nothing has changed. The domain is now completely inaccessable. My only option is to ask my client to delete it and recreate it. (Although, last time I did this Plesk didn't delete the domain properly and I spent hours manually configuring the psa database to fix it.)
     
  15. ecohosting

    ecohosting Guest

    0
     
    Hey shortcut,

    where can we find these? I don;t see them anywhere on the SWSoft site. As well, you know if it fixes the permissions issue?

    Thanks,
    G
     
  16. secrecys

    secrecys Guest

    0
     
    Hi!

    I'm having this problem too..

    I'v already changed the user to the ftpuser and pass to the new pass and it's not working..

    This problem is affecting all my domains!

    Could you tell me what configurations you have at the Default Web Site and DefaultAppTool?

    How can I get the password for the SERVERNAME\IUSR_SERVERNAME ?

    Coul you help me pleaassseeee ;)

    Best Regards,

    Eugenio
     
Loading...