• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

SiteBuilder 4.5 Installation Error, please help.

P

PremF

Guest
Hello,

I have installed SiteBuilder 4.5 by an Autoinstaller downloaded from http://www.parallels.com/download/sitebuilder4/#CENTOS5X86_64.

Packages were installed with this error:
[FATAL] No suitable PHP found
There were some configuration errors, check logs
The packages were installed successfully.

Here is my php detail:
# php -v
PHP 5.2.11 (cli) (built: Sep 21 2009 14:52:42)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.

I have tried to redefine php path by using:
# sb_config --phpcli_path /opt/php52/bin/php5 --phpcgi_path /opt/php52/cgi-bin/php5
(from the suggestion in this topic: http://forum.parallels.com/showthread.php?t=81523)

But it also showed the same error as before:
# sb_config --phpcli_path /opt/php52/bin/php5 --phpcgi_path /opt/php52/cgi-bin/php5
[FATAL] No suitable PHP found
There were some configuration errors, check logs
Logs saved to /usr/local/sitebuilder/tmp/sb_config-1001051638.log

When I tried to set admin user/password via Sitebuilder Setting in Plesk.
There's an error:
Error: Unable to retrieve the information from the Sitebuilder system:
SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://sitebuilder.webnity.com/ServiceFacade/SystemWebService.asmx?WSDL'

Please suggest.
 
As possible reason problem can be caused by inconsistency of package php5-ioncube-php52, for example. Try to check it with something like:
rpm -V php5-ioncube-php52-4.5.0-centos5x86_64.08052912

(note that you can have other name of installed php5-ioncube-php52 package - use correct there). Also chec content of /usr/local/sitebuilder/tmp/sb_config-1001051638.log log file. Most probably you will find something useful there.
 
Last edited:
Back
Top