1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Sitebuilder upgrade 1.1 to 1.1.1 error

Discussion in 'Legacy Sitebuilder Software' started by dvdpa, Apr 4, 2005.

  1. dvdpa

    dvdpa Guest

    0
     
    Hi

    I had a working 1.1 and I upgraded to 1.1.1 and now get errors trying to access admin. Here is the error
    Process of installation has come to the end with failure. Database tables have not been created...
    Please, check it...
    Details see in install log file

    (log file)
    [4-April-2005 14:25:2] Log of installation process
    [4-April-2005 14:25:2] Create dirs...........
    [4-April-2005 14:25:2] The dir "temp" is created ...Ok
    [4-April-2005 14:25:2] The dir "work" is created ...Ok
    [4-April-2005 14:25:2] The dir "users" is created ...Ok
    [4-April-2005 14:25:2] Create config file..........
    [4-April-2005 14:25:2] Unlink file "/usr/local/sitebuilder/include/config.php" ..... Ok
    [4-April-2005 14:25:2] Process sql-query: CREATE DATABASE sitebuilder
    [4-April-2005 14:25:2] Result:...... Error: (code=)
    [4-April-2005 14:25:2] Error on query >> CREATE DATABASE sitebuilder
    [4-April-2005 14:25:2] Create DataBase "sitebuilder"..... fail
    [4-April-2005 14:25:2] Create tables...........
    [4-April-2005 14:25:2] Process of installation has come to the end with failure. Database tables have not been created... Please, check it...

    Any help would be welcome

    Thanks

    Chuck
     
  2. softpac2000

    softpac2000 Guest

    0
     
    If you have Site Builder for Plesk Publishing, you do NOT need to install Site Builder! It is already installed as part of the Plesk 7.5 release.

    All you need to do is access is:

    1. sitebuilder.yourdomain.com
    2. Select "LOGIN TO ADMIN PANEL"
    3. User name = root
    4. Password = sitebuilder

    You may change the user name and password once you login for the first time!...

    Hope this helps!
    Ricardo...:cool:
     
  3. dvdpa

    dvdpa Guest

    0
     
    Wow I had no idea. I had sitebuilder installed with 7.16 pleask
    (sitebuilder 1.1) I then upgraded to 7.5.1 (still watching 7.5.2).

    The trouble is I already had is install the upgrade and now when I access sitebuilder.domain.com and try to set pass I get that error. How should I go about correcting? Remove sitebuilder?

    Thanks for you help

    Chuck
     
  4. softpac2000

    softpac2000 Guest

    0
     
    Whatever you do! Make a FULL system backup first!...

    I wouldn't try to remove Site Builder!... It might mess up your installation!...

    I would send a note to tech support and they might give you an answer hopefully for free!....

    Or maybe wait for someone in the forum that has had the same issue!

    The reason I think it is not letting you create the tables is because they already exist!...

    Sounds like you have "SiteBuilder for General Server Publishing" not the "SiteBuilder for Plesk Server Publishing"....

    If that's the case you might have to do it using the regular Site Builder installation!... Not sure on this!

    Following the errors above I will give you my opinion on how to fix this but make sure you have your backup!...

    Looks like you aborted the installation at some point and then tried to install or something like that.....

    You would need to remove the Sitebuilder tables and Database before trying to install again.... You might also have to remove directories created for sitebuilder. Perhaps uninstalling and re-installing might do the job.

    If you have clients already using Site Builder DON'T remove anything at all!...

    Installation should work fine after doing the above!

    Good Luck! and Remember the Full Sytem Backup!
    Ricardo...:cool:
     
  5. RevMagi

    RevMagi Guest

    0
     
    What are you talking about

    I have no clue what you are talking about !!!! Sitebuilder is not installed with Plesk. I have over 20 Plesk servers and the only way to put Sitebuilder on them is to install them. I am also having issues with version 1.1.1 as I am not able to login to the admin interface either. I have an e-mail to sitebuilder support and will post what they find for a fix if they tell me.

    As for what comes with Plesk, the sitebuilder in it is a link to install Mambo. It also has PPWE, but even that requires a license.
     
  6. softpac2000

    softpac2000 Guest

    0
     
    SiteBuilder 1.1.2 for Plesk Publishing is installed by Plesk 7.5 for Windows by default. This I found out from SW-Soft. I did not install SiteBuilder in a separte install and I am currently using it. A license is required though to be able to publish etc...

    Not sure if this is the case with SiteBuilder under Unix version of Plesk.

    Also if you want to use the "SiteBuilder for General Server Publishing" that one you need to install separately. Not sure which version you have.

    And you are correct, SiteBuilder icon in Plesk refers to the Mambo CMS software and not to SW-Soft SiteBuilder. They should probably rename it to Mambo to prevent the confusion.

    Hope this clears the confusion!
    Ricardo...:cool:
     
  7. dvdpa

    dvdpa Guest

    0
     
    Hi all

    I have mine now working after emailing tech support. Sitebuilder does not come with plesk you need to download and install. On my machine oringinaly logged in as root
    to admin the sitebuilder but this new install wanted my root
    login to mysql with is the same as my plesk server it is running on. So for the install script I needed to use admin not root with my servers password and that go me to the normal front end wizard. Then when I logged into the sitebuilder admin I needed to use root again not admin to gain access...

    Hope this helps

    Chuck
     
  8. softpac2000

    softpac2000 Guest

    0
     
    SiteBuilder 1.1.2 for Plesk Publishing is installed by Plesk 7.5 for Windows by default.

    Here is the email from support:


    Hello Ricardo,

    Plesk 7.5 contains SiteBuilder. All you need is SiteBuilder license. It
    has been sent to you.

    Thanks,
    --
    Nadezhda Berdnikova
    Online Store Service Representative
    SWsoft, Inc.



    Ricardo A. Garcia wrote:

    > Hi,
    >
    > I just purchased a license of "SiteBuilder, 300 Sites for Plesk
    > Publishing". I have a Windows Server2003 with Plesk 7.5. and I can't
    > find the link under "SiteBuilder for Installation on Plesk
    > ServersSiteBuilder for Installation on Plesk Servers" to download the
    > software for SiteBuilder for Windows.
    >
    > Please let me know what to do!
    >
    > Thanks!
    >
    > Ricardo...
     
  9. RevMagi

    RevMagi Guest

    0
     
    Ok Softpac, that has to be something they are doing with Windows Plesk but the majority of us in the forum are using *nix servers. On *nix. it is not installed.

    The problem is the mod_jk tried to alias all admin dir for tomcat. Here is what they did to get mine working. The install was fine, the mod_jk was breaking it.

    The problem was in the following directives in:

    /etc/httpd/conf/mod_jk.conf

    #
    # The following line makes apache aware of the location of the /admin context
    #
    #Alias /admin "/var/lib/tomcat4/server/webapps/admin"
    #<Directory "/var/lib/tomcat4/server/webapps/admin">
    # Options Indexes FollowSymLinks
    #</Directory>

    #
    # The following line mounts all JSP files and the /servlet/ uri to tomcat
    #
    #JkMount /admin/servlet/* ajp13
    #JkMount /admin/*.jsp ajp13
    #JkMount /admin/j_security_check ajp13

    #
    # The following line prohibits users from directly access WEB-INF
    #
    #<Location "/admin/WEB-INF/">
    # AllowOverride None
    # deny from all
    #</Location>


    RevMagi
     
Loading...