1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sites In IIS stopped

Discussion in 'Plesk for Windows - 8.x and Older' started by rimonline, Oct 7, 2004.

  1. rimonline

    rimonline Guest

    0
     
    I'm having some probs bringing our new Plesk 7 Server up. I added one domain, but in IIS it says the domain is stopped. The "webmail" and "sqladmin" sites are stopped also. I can't preview the site through http://ipaddress/domain.com either, it just gives a big 404 error message.

    I see nothing wrong in the Plesk Control Panel. Can someone help me debug why this might be happening?

    Many thanks,

    Scott MacDonald
    Regional Internet Media Inc.
     
  2. jaytee

    jaytee Guest

    0
     
    Did you check Event log for error messages? What happens when you start the domain in IIS Admin?
     
  3. rimonline

    rimonline Guest

    0
     
    When I try to start the site in IIS it errors with:

    The process cannot access the file because it is being used by another process.

    There are two event log messages:

    W3SVC - Cannot register the url prefix http://<domain.com>:80/ for the site 20021. The site has been deactivated. The data field contains the error number.

    HTTP - Unable to bind to the underlying transport for 0.0.0.0:80. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine.



    Any help would greatly be appreciated.

    Thanks,

    Scott
     
  4. rimonline

    rimonline Guest

    0
     
    *****Resolved*****

    If anyone else runs into this, try and install the 2003 Support Tools on the server which should be on Disc 2 of your CD pack or under [cdrom]:\support

    Then run the httpcfg utility on the command line. From what i've read on the internet you should run:

    Viewing all off the IP addresses that the HTTP API is listening on.

    httpcfg query iplisten

    If any don't need to be there then run:

    httpcfg delete iplisten -i <IPaddress>:80

    And finally you need to add your ethernet card ip with:

    httpcfg set iplisten -i <IPaddress>:80

    This solved my problem and maybe it will for you to.

    Scott
    Regional Internet Media, Inc.
     
  5. visupport

    visupport Guest

    0
     
    Another solution to reconfigure IIS websites to Plesk websites:

    1. Set registry parameter HKEY_LOCAL_MACHINE\SOFTWARE\PLESK\PSA Config\Config\IIsConfigured = 0

    2. Run websrvmng --install

    3. Run websrvmng --reconfigure-all
    :)
     
  6. rimonline

    rimonline Guest

    0
     
    I found a previous post with similar directions but don't think it had the #2 stop you mentioned above, and maybe why that's why it didn't work for me.

    Thanks for the help! :)

    Scott
     
Loading...