1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

SMTP Problems with Outlook

Discussion in 'Plesk for Linux - 8.x and Older' started by jcevans, Jun 10, 2005.

  1. jcevans

    jcevans Guest

    0
     
    Since upgrading to 7.5.3 (Linux), I have lost all ability to send email from Outlook using SMTP. I've tested it on two different machines with the same problem on each.

    I am able to send SMTP email through Netscape, and my webmail is working fine.

    I've read through all of the posts that deal with this issue, and the only solution that I see is on a windows-based machine where people have set up an open relay for limited IP addresses.

    This doesn't appear to be an option in Linux. It's either completely open or not.

    Has anyone found a solution? Clients are not too happy right now.

    Thank you.
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    In Outlook, make sure you place a checkmark in the 'My Server Requires Authentication', and it will be able to send just fine.

    In the Plesk control panel in Server, Mail, make sure it has a checkmark for SMTP and is selected for 'authorization is required'. If you have selected 'Only use of full POP3/IMAP mail accounts names is allowed', then in Outlook, the account login (user login) would have to be the full email address (user@domain.com), not just 'user'.
     
  3. jcevans

    jcevans Guest

    0
     
    Thank you James. I appreciate you taking time to make some suggestions.

    The problem is that SMTP email was working FINE prior to the upgrade. Outlook worked fine. Authentication was checked in all 30 or so email accounts, and all email accounts worked fine.

    Since the upgrade, SMTP from Outlook does not work. Nothing has changed as far as Outlook configuration. Authentication is still checked in Outlook, and SMTP authentication is checked in Plesk.

    I have tried every imaginable configuration and combination and nothing works.

    As I said, Netscape works fine and Webmail works fine. Just Outlook that is the problem.

    I can get Outlook to work if I reconfigure the email account as IMAP, but I prefer SMTP and that is what should work since it worked prior to the upgrade.

    Thanks again. Additional suggestions?
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ah, sorry. I did a 'drive by' posting and missed the part about 'after upgrading...'. My apologies. I'll have to digest the full info before responding again.

    What is the error message/code which Outlook comes back with?

    And when Outlook tries checking the mail, do your server logs show any errors?
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ok, please try either increasing the Timeout in Outlook (just as a test), by default MS sets it low.

    Other thing to try is to:

    Run /etc/rc.d/init.d/xinetd stop

    Edit the file /etc/xinetd.d/smtp_psa

    server_args = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true

    Check that you have -Rt0 added to the server_args

    Then run /etc/rc.d/init.d/xinetd restart
     
  6. jcevans

    jcevans Guest

    0
     
    OK. I had tried adding the -Rt0 to the smtp_psa file, but didn't know how to stop and restart the xinetd. Thanks!

    Now I get a different error from Outlook:

    Outlook could not connect to the outgoing mail server (SMTP). The problem could be your SSL or port settings for the for the outgoing server. Verify your port and SSL settings under More Settings on the Advanced tab.

    The original error I was receiving from Outlook was:

    The specified server was found, but there was no response from the server. Please verify that the port and SSL information is correct.

    Ugh.
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Make sure you don't have Outlook setup for 'Secure Password Authentication' or 'This server requires a secure connection (SSL)' do you? Which would also cause auth/connect problems.

    Check these settings and make sure it is set for port 25, without SSL
     
  8. jcevans

    jcevans Guest

    0
     
    Correct. The "Log On using the Secure Password Authentication (SPA) is not checked.

    There are quite a few posts about this throughout the forum section, and I've read through everything, but nothing seems to help.

    It's really a strange bird.
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    And what about the Advanced settings about SSL? Are they also not selected?
     
  10. jcevans

    jcevans Guest

    0
     
    Yes. Sorry, forgot to include that in the last post. They are not selected. I did try selecting them to see if that helped, but it did not.
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Strange bird indeed. I have clients who use Outlook 2000/XP (aka 2002)/2003 with 7.5.3 and other than those issues already posted, I have not had any of them have any problems connecting or authenticating.

    Obviously your SMTP is working, port 25 accessible (not a firewall issue), etc since Netscape mail is able to function as well as webmail.

    And Outlook in IMAP mode works, but not SMTP mode... hmmm.

    You could try starting Outlook with any combination of switches:
    /safe
    /rpcdiag
    /nocustomize
    /noextensions

    See:
    http://office.microsoft.com/en-us/assistance/HP010031101033.aspx
    for more info on Outlook switches.

    I give up for now...sorry.
     
  12. jcevans

    jcevans Guest

    0
     
    Thanks for trying. I greatly appreciate it.
     
  13. ionuts71

    ionuts71 New Pleskian

    22
    70%
    Joined:
    Jul 7, 2005
    Messages:
    7
    Likes Received:
    0
    Sending' reported error (0x8004210B)

    I have the same problem regarding sending e-mails using Outlook. Until two days ago, everithing was OK. After that, without any modification on the server or Plesk, I receive the following error message when I try to send mails (in fact all my clients receive the same message):

    Task 'Office - Sending' reported error (0x8004210B) : 'The operation timed out waiting for a response from the sending (SMTP) server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'

    I have Plesk 7.5.3 on SuSe Linux.
    Did you find a solution?
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    There are several possible causes for this Outlook error (most are related to the Outlook XP/2002/2003 versions):

    1. Increasing the timeout value in Outlook:
    - Start Outlook
    - Click Tools, then E-mail Accounts
    - Select View or Change existing e-mail accounts, Click Next.
    - Double Click on your email account
    - Click More Settings
    - On the Advanced tab, change Server Timeout from 1 minute to a higher value. (Outlook counts 1 minute awfully fast compared to my watch!, another MS bug, or in some cases related to anti-virus scanning emails taking too long, I know Norton's email scanner is taking longer now than it did in the past, I won't even begin to rant about how messed up McAfee is nowadays...)

    2. Check that your SSL cert has not expired

    3. Check for latest updates to Office/Outlook, several issues are fixed with MS updates to Office/Outlook (Office XP SP3 or hotfix 'post SP2 Hotfix Package dated September 5, 2003 or newer)

    4. If you have Return Receipts (like Read Receipt) option turned on, try turning it off

    5. If the email has attachment(s), make sure they are within the size limits set on the server side.

    On many support forums (not just Plesk) there have been many many reports of this error occuring with Outlook XP/2002/2003 (usually not with the 2000 version). The suggestions I have written above have resolved the problem in almost every case (not all of them are needed for every case).

    This Oulook error has been reported to occur on servers running many different control panels and even some servers not running a control panel. It appears to be due to bugs in Outlook. The fact that it 'used to work' and now it does not, may be due to the fact that the Windows Automatic Updates feature may have downloaded some updates and installed them onto the client computers (yes, even with no notification that it is doing it).

    I personally have had clients running Outlook 2002 and 2003 which have stopped working for no apparent reason, in *all* cases, it turned out to be Outlook at fault, not the server(s).
     
  15. reybie

    reybie Guest

    0
     
    Me too!

    I too am trying to solve this problem on one of my domains. I am not sure if the length of the username has something to do with it though because one address is able to send email fine but not the other one.

    ajhc.payroll@domain can send
    ajhc.administrator@domain cannot

    It keeps prompting for the password when using Outlook Express.


    Edit: username length doesn't matter, I created an email address with the same length as ajhc.administrator and it could send mail.

    Edit2: Well, I give up. It worked when I removed the @domainname.com part of the username. I don't know anymore. The other email addresses send email just fine with the @domainname.com suffix.
     
Loading...