1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

smtp virtual server don't start

Discussion in 'Plesk for Windows - 8.x and Older' started by satvader, Jan 26, 2004.

  1. satvader

    satvader Guest

    0
     
    After looking around with the problem of not been able to send messages from the webmail I get to know that this service has to be runnong, I get to the internet services and find out that the smtp virtual service or server is stopped, I try to start it but I receive a message about time out and to look at the report log

    am I missing any configuration on it?

    I will apreciate any coment or help!

    thanks in advance
     
  2. x75

    x75 Guest

    0
     
    The Plesk Mail Server Mail Enable is already running on the port 25, so in order for the virtual smtp-server to run, you need to change it's port from 25 to something else.
    For example 2525.

    You do that by right clicking on the virtual smtp-standardserver for SMTP.
    Then were it says Ip-Address click on the button behind it. Should say something like "extended" (sorry I only have the german version).
    Then Click on edit and change the Port number.
    Click on OK, again OK, again Ok.

    Now make sure the SMTP-Service and the Simple Mail-Transport Service are set to "Automatic" in you lokal Services.

    Now you should be able to start the virtual-smtp-server.

    Hope This Helps
    Johannes
     
  3. satvader

    satvader Guest

    0
     
    Thanks for helping me!!

    so in order to have my webmail working properly on plesk do I neceserely need to have the smtp virtual server on windows running?
     
  4. x75

    x75 Guest

    0
     
    I did not say that :)
    It depends on your webmail.
    For example if you use an ASP based Webmail, it might help.

    But I can't tell you if it will solve your Problem with your Webmail.
    But it should fix you Problem with the virtual SMTP Server.

    Johannes
     
  5. ea30

    ea30 Guest

    0
     
    asp sending mail

    Hi Hammersen,

    i have my SMTP working in my IIS

    But when I try to send email from ASP, it gives 500 Internal Server Error.

    In the log file, it says:
    Server.CreateObject_Failed 80

    My ASP code is very standard and simple, it works on other server. Any idea?

    Sincerely,
    Edward Au
     
  6. Redglue

    Redglue Guest

    0
     
    hey Edward -

    are you using win2k or win2k3

    if win2k3 - then it is probably a cdonts issue.
    win2k3 uses cdosys instead - cdonts.dll does not exist

    very easy to switch from cdonts to cdosys use:

    Server.CreateObject("CDO.Message") instead of "CDONTS.NewMail"

    and make sure the body object is set to (example: obj.body) is set to either obj.HtmlBody or obj.TextBody


    if win2k then it is either permissions, corrupted file, or non-registered dll in the registry

    and Hammersen hit it right on the head - MailEnable will use port 25 and so the local smtp server will fail to use 25 and will not start - this is common with most windows mail apps. i always use port 26, but 2525 or any other unused port will work.
     
  7. siren@

    siren@ Guest

    0
     
    A new twist. When you first install Plesk, or upon installation of SP1 it automatically Disables IIS SMTP. Verify it isn't disable and it set to automatic, not manual, so it loads on startup every time.
     
  8. ea30

    ea30 Guest

    0
     
    Yo Redglue,

    Sorry for my novice on this! Your instructions are working for my W2K3 box, now go and work on my W2K.... sigh.... :)

    Here are some tips for those who are running W2K3, set the following in order for ASP to send email (at least in Plesk6.5.1):

    Go to Computer Management > Service to set SMTP from DISABLE to AUTOMATIC

    Go IIS Management > Default SMTP Virtual Server. Under "General" tab, click "Advance" set port to something other then port:25

    (There is another port setting under "Delivery" tab which is set to port 25, do NOTHING to it)


    Following asp script should work:

    <% Dim objMessage

    Set objMessage = CreateObject("CDO.Message")
    objMessage.Subject = "Example CDO Message"
    objMessage.Sender = "xx@xxx.com"
    objMessage.To = "xx@xxx.com"
    objMessage.TextBody = "This is some sample message text send using ASP COD.Message Object."
    objMessage.Send

    response.write "Mail was Sent"

    %>

    Thks Redglue & ddreams
     
Loading...