• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved [SOLVED] Error when trying to login

kersian

New Pleskian
Hello Iam having this problem since today, when I enter the url for login Im getting this:

ERROR: Uncaught exception 'Zend_Log_Exception' with message '"/var/log/plesk/panel.log" cannot be opened with mode "a"' in /usr/local/psa/admin/externals/Zend/Log/Writer/Stream.php:81 Stack trace: #0 /usr/local/psa/admin/plib/Plesk/Log.php(69): Zend_Log_Writer_Stream->__construct('/var/log/plesk/...') #1 /usr/local/psa/admin/plib/Plesk/Log.php(359): Plesk_Log::init() #2 /usr/local/psa/admin/plib/Plesk/Log.php(262): Plesk_Log::get() #3 /usr/local/psa/admin/plib/Plesk/Log.php(168): Plesk_Log::log('panel', 3, 'SQLSTATE[HY000]...') #4 /usr/local/psa/admin/plib/PleskException.php(26): Plesk_Log::err('SQLSTATE[HY000]...') #5 /usr/local/psa/admin/plib/PleskException.php(13): report_crash('SQLSTATE[HY000]...', Array, 'Zend_Db_Adapter...', 500, Object(Zend_Db_Adapter_Exception)) #6 [internal function]: plesk_exception_handler(Object(Zend_Db_Adapter_Exception)) #7 {main} thrown (Stream.php:81)

Thanks for any help!
 
sorry for double posting, but in the live web I get error to connect with SQL and in Roundcube have:
DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.
 
Yes I did, this error I didnt find it over the internet, and did repair without success, dunno what else to do.
 
Thanks UFHH01 finally I could, I had to re install mariadb that was giving me a lot of problems, now I have another error:
Internal error.
ERROR: Uncaught exception 'Zend_Log_Exception' with message '"/var/log/plesk/panel.log" cannot be opened with mode "a"' in /usr/local/psa/admin/externals/Zend/Log/Writer/Stream.php:81 Stack trace: #0 /usr/local/psa/admin/plib/Plesk/Log.php(69): Zend_Log_Writer_Stream->__construct('/var/log/plesk/...') #1 /usr/local/psa/admin/plib/Plesk/Log.php(359): Plesk_Log::init() #2 /usr/local/psa/admin/plib/Plesk/Log.php(262): Plesk_Log::get() #3 /usr/local/psa/admin/plib/Plesk/Log.php(168): Plesk_Log::log('panel', 3, '"/var/log/plesk...') #4 /usr/local/psa/admin/plib/PleskException.php(26): Plesk_Log::err('"/var/log/plesk...') #5 /usr/local/psa/admin/plib/PleskException.php(13): report_crash('"/var/log/plesk...', Array, 'Zend_Controller...', 500, Object(Zend_Controller_Exception)) #6 [internal function]: plesk_exception_handler(Object(Zend_Controller_Exception)) #7 {main} thrown (Stream.php:81)

I did my research and check files permission for /var/log/plesk/panel.log
and it is: -rw-r-----r 1 psaadm root 36462

I did what I found in other post: chown -R psaadm:root /var/log/plesk
But the error persist, when I try to do soemething in the Plesk like add FTP or see MyPHPAdmin.
I had run repair bootstrap too.
Appreciate your help.
 
Yes I did this:
run bootstrap repair
chown -R psaadm:root /var/log/plesk/
And my permissions are:

/var/log/plesk/
drwxr-x--- 5 psaadm root 4096

/var/log/plesk/panel.log
-rw-r----- 1 psaadm root 36462

What Im missing?
Thanks
 
psa.png


When I start PSA it doesnt show that error, only drweb but dunno why, here is the details:

drweb.png



And if I do something like create FTP or whatever:
plesk2.png


Thanks for your time!
 
Last edited:
Some toughts for why Plesk is telling me that my permissions are wrong and I check and they are ok?
I cannot perfom anything in the plesk panel becouse that error , need some advice.
Thanks
 
For everyone who finds this thread through search engines like I did:

I had the same problem, and I was able to resolve it without having to reinstall everything on the server. I followed the steps outlined in this guide and executed the commands indicated here: Unable to access Plesk: /usr/local/psa/admin/logs/panel.log cannot be opened with mode “a” - Support Cases from Plesk Knowledge Base

Give it a try and see if it resolves the issue for you as well.
Thanks a lot. It worked for me.
 
Back
Top