1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Spam Assassin stops working (twice now)

Discussion in 'Plesk for Linux - 8.x and Older' started by Protean, Feb 24, 2006.

  1. Protean

    Protean Guest

    0
     
    In the last 2 months the SpamAssassin with my Plesk 7.5 install has stopped working. It worked great for the 8 months prior to this. It stopped deleting or tagging the messages. I went and turned setting on and off, but nothing changed. Then I set the SpamAssassin settings under services to use "personal settings" only, then went and adjusted a few mail accounts. It started working again.
    Now it is 3 weeks later and it just stopped working for all domains and email accounts again. I did not change anything.

    I restarted the service and tried changing the settings on a few email accounts, but it is stil not working.
     
  2. gregg@

    gregg@ Guest

    0
     
    Protean,
    Do you have any log file snippets from /usr/local/psa/var/log/maillog that you can post to help out?

    Another suggestion, assuming you are on some **ix flavor of Plesk, check the directory and files in the .spamassassin directory for all your users and the system in general. THere was a time a few weeks ago that the owner of the files had gotten messed up and they could not be opened. I set the permissions and owners to match other users who actually worked and the problem went away.

    There is something very odd happening on my FC3 Linux box. some of the permissions on files and directories seem to be getting changed. I didn't investigate the spamassassin issue in depth, but any future occurrences will be.
     
  3. Protean

    Protean Guest

    0
     
    I looked at the log file and there were no spamd entries at all until this morning. This morning I turned "server wide" settings on in Plesk, as well as "personal" and then went into some individual mailboxes and turned off the "use server wide" checkbox. All of the sudden it started working again.

    I don't know how to tell if it is working for all mailboxes. There are a lot of domains and mailboxes on this server. I will have a friend help me look at the individual things in the .spamassassin directory you mentioned. It seems like those are probably ok since it is working once again.

    Not sure what else to look at. We are looking into using a free solution for antispam and antivirus, but apparently this is a lot more difficult to setup in this newer plesk. We had it a free solution on the old server (plesk 6) and it never failed.

    - matt
     
Loading...