1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Spamassasin error

Discussion in 'Plesk for Windows - 8.x and Older' started by xyla, Jun 29, 2006.

  1. xyla

    xyla Guest

    0
     
    Error: Cannot exec 'spammng --train-spam --filename=C:/Program Files/SWsoft/Plesk//tmp/spm51E.tmp --password=******* --mailname=wilco.wings@xyla.nl':
    SpamAssassin version 2.64
    Unable to train spamassasin: SpamAssassin version 2.64
     
  2. renleon

    renleon Guest

    0
     
    Hi xyla

    I had the same error. Im guessing you have performed an upgrade, not a fresh install. Basically you have the wrong version of spamassassin installed.

    Plesk 7.6 should have installed 3.1.1, you have 2.64.

    I contacted my server teck support and they got swsoft to fix the problem.

    If your using mailenable standard you may want to check to see if that was upgraded. The old version is 1.9, the new is 1.95. Login to the remote desktop of your server and goto Start > Program Files > Mailenable -> Diagnostic, to check the version.

    Swsoft had to upgrade this for me too, as it was the old version of 1.9.
     
  3. xyla

    xyla Guest

    0
     
    Thanks,

    Plesk Components Management says:

    MailEnable Standard 1.95
    SpamAssassin 3.1.1

    But the error shows an older version of spamassassin.

    What's the best approach now?
     
  4. renleon

    renleon Guest

    0
     
    My components also showed the correct versions, but it was wrong.

    Login via the remote desktop and check mailenable via the diagnotic.

    Then open a command prompt (start > run > cmd.exe)

    And type spamassassin --version

    This will probably return version 2.64 which will confirm its running the wrong version.

    I think all swsoft did was upgrade my mailenable to version 1.96 and upgrade spamassassin to the correct version (3.1.1). Im not sure how they did it, or if they did anything else.

    After confirming the versions I would get in contact with your server support people and get them to fix it. They will probably pass it on the swsoft to sort out.

    Who do you have your server with?
     
  5. Webplus

    Webplus Guest

    0
     
    My Spamassassin returned this:
    spamassassin: spamassassin script is v3.001000, but using modules v3.001001

    Is it wrong version?
    (It's not working since 7.6 update...)
     
  6. renleon

    renleon Guest

    0
     
    Thats the correct version for 7.6

    How is it not working? Is all spam getting through?
     
  7. xyla

    xyla Guest

    0
     
    I uninstalled Spamassassin in the Plesk setup. Then renamed the folder C:\Program Files\SWsoft\Plesk\Additional\SpamAssassin_old.

    Then installed Spamassassin again via Plesk setup.

    No errors anymore.
     
  8. Webplus

    Webplus Guest

    0
     
    No, Spamassassin isn't filtering any message.

    I'll try to do what xyla did.

    xyla, if I do this, Plesk will set the NTFS permissions again?
    I've set all permissions right, and I'm afraid Plesk reconfigure all permissions wrong again if I try to reinstall Spamassassin.

    Thanks.
     
  9. Webplus

    Webplus Guest

    0
     
    I tried what you said (renaming the dir and reinstalling) but Spamassassin continue don't running...

    I can see too there's NO perl.exe running on Windows Task Manager. As I know, PERL is necessary to Spamassassin to work.

    Very strange...

    Any news?
     
  10. xyla

    xyla Guest

    0
     
    I only had promission problems on my email component CDONTS and ASPemail after the upgrade from 7.56.->7.6.0.

    These problems didn't came back after reinstalling spamassassin.
     
Loading...