1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Spamassassin Just Stopped Working

Discussion in 'Plesk for Linux - 8.x and Older' started by lloy0076, Jun 12, 2006.

  1. lloy0076

    lloy0076 Guest

    0
     
    I'm using Debian still on 7.5.4.

    Specifically:

    psa v7.5.4_build75051014.16 os_Debian 3.1

    beijing:/opt/psa/bin# cat /etc/apt/sources.list
    #deb file:///cdrom/ sarge main

    deb http://autoinstall.plesk.com/debian PSA_7.5.4/
    deb http://ftp.filearena.net/pub/debian/ stable main
    deb http://ftp.au.debian.org/debian/ stable main
    deb-src http://ftp.au.debian.org/debian/ stable main

    deb http://security.debian.org/ stable/updates main

    I have the following spamassassin(s) installed:

    beijing:/opt/psa/bin# dpkg -l | grep spam
    ii psa-qmail-rbls 0.70-debian3.1 Antispam DNS-based block lists
    ii psa-spamassass 7.5.4-debian3. SpamAssassin support for Plesk.
    ii spamassassin 3.0.3-2 Perl-based spam filter using text analysis
    ii spamc 3.0.3-2 Client for SpamAssassin spam filtering daemo

    Spamassassin has suddenly stopped checking messages. Here's what I did:

    1. Purchase spamassassin upgrade
    2. Installed spamassassin
    3. Turned it on for all users using the group operation
    4. Checked to see if it worked

    It did 4 days ago.

    5. Get back to work
    6. Check to see if it worked

    It's stopped working.

    It is running:

    popuser 6204 0.0 2.3 22952 20896 ? Ss Jun11 0:00 /usr/sbin/spamd --username=popuser --daemonize --helper-home-dir=/var/qmail --max-children 5 --create-prefs --nouser-config --virtual-config-dir=/var/qmail/mailnames/%d/%l/.spamassassin --pidfile=/var/run/spamd/spamd_light.pid --socketpath=/tmp/spamd_light.sock --siteconfigpath=/dev/null
    popuser 6205 0.0 2.3 23336 21348 ? Ss Jun11 0:00 /usr/sbin/spamd --username=popuser --daemonize --helper-home-dir=/var/qmail --max-children 5 --create-prefs --nouser-config --virtual-config-dir=/var/qmail/mailnames/%d/%l/.spamassassin --pidfile=/var/run/spamd/spamd_full.pid --socketpath=/tmp/spamd_full.sock

    There's no qmail-scanner anywhere or anything and I can't see any logging by spamassassin at all.

    DSL
     
  2. lloy0076

    lloy0076 Guest

    0
     
    Bletch!

    I enabled it in:

    /etc/default/spamassassin

    ...and restarted it via the Plesk interface and now it seems to be working.

    (until it stops working again)

    DSL
     
Loading...