1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SpamAssassin troubles

Discussion in 'Plesk for Linux - 8.x and Older' started by HetIsLarsje, May 9, 2006.

  1. HetIsLarsje

    HetIsLarsje Guest

    0
     
    Hi all,

    To fight the spam hitting our server, I started to work with the Rules Du Jour for SpamAssassin. All seems perfectly fine, but for one thing:
    - I cannot get the 'lint' command running...
    I only get 'command not found'. Or in other words, where does Plesk hide the corresponding 'executable' for SpamAssassin ( and the lint command) on a FreeBSD machine and PLESK? How do you restart SpamAssassin?

    I'm well aware that it should be a simple answer, but I cannot find it on the forum or elsewhere...

    It concerns Plesk 7.5 Reloaded on FreeBSD 4.11. Rules Du Jour are/is? installed following Rules Du Jour website

    My config file reads:
    SA_DIR="/usr/local/psa/spamassassin/etc/mail/spamassassin"
    MAIL_ADDRESS="email@domain.org"
    SA_RESTART="/usr/local/psa/rc.d/psa-spamassassin restart"

    TRUSTED_RULESETS="***"

    Thanks for any help.
     
  2. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    type the following on command line

    whereis spamassassin

    this will give you the path to the binary.
     
  3. jspilon

    jspilon Guest

    0
     
    whereis doesnt always return something

    you may want to do this

    # find / -iname spamassassin
     
  4. HetIsLarsje

    HetIsLarsje Guest

    0
     
    Yeah, tried that

    Thanks for the answers.

    I already tried to find spamassassin:

    admin@server$ whereis spamassassin
    Warning: couldn't stat file /usr/X11R6/man!
    spamassassin:

    admin@server$ locate spamassassin
    /root/.spamassassin
    /usr/local/psa/admin/htdocs/domains/mail/spamassassin.php3
    /usr/local/psa/admin/htdocs/domains/mail/spamassassin_train.php3
    /usr/local/psa/admin/htdocs/server/spamassassin.php
    /usr/local/psa/admin/plib/api-cli/spamassassin.php
    /usr/local/psa/admin/plib/templates/spamassassin.tpl
    /usr/local/psa/admin/plib/templates/spamassassintrain.tpl
    /usr/local/psa/admin/plib/templates/spamassassinuser.tpl
    /usr/local/psa/bin/spamassassin.sh
    /usr/local/psa/man/man1/spamassassin.1
    /usr/local/psa/rc.d/psa-spamassassin
    /usr/local/psa/spamassassin
    /usr/local/psa/spamassassin/bin
    /usr/local/psa/spamassassin/bin/sa-learn
    /usr/local/psa/spamassassin/bin/spamassassin
    /usr/local/psa/spamassassin/bin/spamc
    /usr/local/psa/spamassassin/bin/spamd
    /usr/local/psa/spamassassin/etc
    /usr/local/psa/spamassassin/etc/mail
    /usr/local/psa/spamassassin/etc/mail/spamassassin
    /usr/local/psa/spamassassin/etc/mail/spamassassin/RulesDuJour
    /usr/local/psa/spamassassin/etc/mail/spamassassin/RulesDuJour/rules_du_jour
    /usr/local/psa/spamassassin/etc/mail/spamassassin/local.cf
    /usr/local/psa/spamassassin/lib
    /usr/local/psa/spamassassin/lib/perl5
    /usr/local/psa/spamassassin/lib/perl5/man
    /usr/local/psa/spamassassin/lib/perl5/man/man1
    /usr/local/psa/spamassassin/lib/perl5/man/man1/spammng.1.gz
    /usr/local/psa/spamassassin/share
    /usr/local/psa/spamassassin/share/spamassassin
    /usr/local/psa/spamassassin/share/spamassassin/languages
    /usr/local/psa/spamassassin/share/spamassassin/triplets.txt
    /usr/local/psa/spamassassin/share/spamassassin/user_prefs.template
    /usr/ports/mail/p5-Mail-SpamAssassin/files/patch-spamassassin.raw
    /usr/ports/mail/qmail-scanner/files/patch-sub-spamassassin.pl

    A very interesting (and long) list, however, anything I try just gives a 'command not found'. Both as admin and as root, using spamassassin, spamd, psa-spamassassin, etc.

    Well, I'll try and look at the installation itself, there also seems to be a problem with adding domains to the whitelist via the Plesk interface. It stops spamassassin. Oh well, something to work on... Too bad the documentation is so... basic.

    I'll get back to you later.
     
  5. HetIsLarsje

    HetIsLarsje Guest

    0
     
    Just for information some of the things I did to get it to work (yes, it does work now!).

    1. There is a known problem with the Plesk 7.5 interface and Spamassassin. You have to upgrade to Plesk 8 to solve it.

    2. Note to self: If you want to run an executable file from within its folder, you need to run it via ./spamassassin. *sigh* Stupid beginners-error. It solves the 'command not found' very nicely...

    3. A symlink is placed pointing from /usr/share/spamassassin/ to /usr/local/psa/spamassassin/share/spamassassin/

    The new RulesDuJour configuration script:

    SA_DIR?="/usr/local/psa/spamassassin/etc/mail/spamassassin"
    MAIL_ADDRESS?="webmaster@domain.org"
    SA_RESTART?="/usr/local/psa/rc.d/psa-spamassassin restart"
    SA_LINT?="/usr/local/psa/spamassassin/bin/spamassassin -D --lint"

    Anyway, thanks all for helping out. You live and learn...
     
Loading...