1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SPF not working

Discussion in 'Plesk for Linux - 8.x and Older' started by tekknix, May 6, 2006.

  1. tekknix

    tekknix Guest

    0
     
    Hi, after Upgrading (without) errors from 7.5.4 to 8.0 and all actual Updates (on S.u.S.E. 9.3) SPF is'nt working at all.

    I've tried to active and deactivate SPF in Cpanel and after proofing my DNS-Config, there is absolute no change.

    I've not a problem with Spam, but someone tries to use my Domain-Names as Sender-Domain.

    Someone can confirm this Error ?

    Please help out of this.

    kind regards
    tekknix
     
  2. Zella

    Zella Guest

    0
     
    Hi,

    Check if you have Perl Mail::SPF::Query installed

    Not done during the Plesk Installation !

    This requires Mail::SPF::Query, a relatively new package that's not yet installed on most machines. You can confirm whether you have it by entering:

    perl -e 'require Mail::SPF::Query'

    If you get the error "Can't locate Mail/SPF/Query.pm in @INC..." you need it.
     
  3. tekknix

    tekknix Guest

    0
     
    Thx, i`ve checked it and it was not installed.

    I`m using S.u.S.E. 9.3, there is no package for it.

    I`ve installed the depending Files PERL-NET and PERL-CID and PERL-SPF from RH9.

    There is no error.

    But there is still no change.

    I am assuming, that the change is done automatically and should be visible in DNS-Config.

    But there is still "the old" config, no additional TXT - Entry for SPF.
     
  4. Zella

    Zella Guest

    0
     
    To make a test, you can always add "manually" a TXT record for SPF within your DNS Config.

    A after that, make a new test.
     
  5. Traged1

    Traged1 Guest

    0
     
    OK, We using PLESK8 on RHEL3ES,

    Here is what I have found:

    We have turned on SPF, have all required packed and perl mods installed, we published spf txt records using the PLESK DNS button for the domains, and upon testing by sending an email to mailto:check-auth@verifier.port25.com this is the result:

    ==========================================================
    Summary of Results
    ==========================================================

    mail-from check: neutral
    PRA check: neutral
    DomainKeys check: neutral (message not signed)


    "neutral" sending domain does not publish any sender authentication policy.

    ==========================================================

    This is not a dns propagation issue as we have setup these txt records over 3 weeks ago.

    So I will use DNS stuff to try and lookup the txt record and this is what I see:

    mydomain.com. TXT IN 86400 ""v=spf1 ip4:216.xxx.xxx.xxx/24 a mx ~all""

    Of cource I have xxx'ed out our IP for security, but do you notice the "" two double quotes in the txt record? Could this be the issue?

    Upon inspection of the domain's actual zone file I see PLESK added:

    mydomain.com. IN TXT "\"v=spf1 ip4:216.xxx.xxx.xxx/24 a mx ~all\""

    Shouldn't this be instead:
    mydomain.com. IN TXT \"v=spf1 ip4:216.xxx.xxx.xxx/24 a mx ~all\"


    :confused:
     
  6. Traged1

    Traged1 Guest

    0
     
    OMG I think I may have entered the "" in the TXT string, Darn I really should get more sleep :) False alarm.
     
  7. d-woo

    d-woo Guest

    0
     
    So in the Plesk 8 Admin

    I click

    1. Domains
    2. choose my domain
    3. DNS
    4. Add New Record
    5. line 1: TXT
    6. line 2: mail.<yourdomain>
    7. line 3:

    here is where my question is:

    Should it be:
    "v=spf1 a mx ~all"

    or
    v=spf1 a mx ~all
     
  8. Traged1

    Traged1 Guest

    0
     
    You should enter:

    v=spf1 a mx ~all

    Without the "" in PLESK as PLESK adds the "" for you in the zonefile.
     
  9. d-woo

    d-woo Guest

    0
     
    Interesting.

    On two domains that I have in Plesk 8

    on the one where I entered
    "v=spf1 a -all"

    DNSStuff.com shows my TXT record to be
    "v=spf1 a -all"
    and DNSReport.com shows that domain to have an SPF record

    *****************
    on the domain where I entered
    v=spf1 a -all

    DNSStuff.com shows my TXT record to be
    "" "v=spf1" "a" "-all" ""
    and DNSReport.com shows that domain to be missing an SPF


    Additionally, it's a good idea to enter a TXT record for both
    mail.yourdomain.com
    and
    yourdomain.com
     
  10. Traged1

    Traged1 Guest

    0
     
    Myabe there is a difference in OS's or Builds, what OS are you using? We use RHEL3
     
  11. d-woo

    d-woo Guest

    0
     
    Plesk version psa v8.0.1_build80060618.11 os_RedHat el4

    Operating system Linux 2.6.9-34.0.1.ELsmp
     
Loading...