1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SQLServer Remote Connection With Managmanet Studio

Discussion in 'Plesk for Windows - 8.x and Older' started by AhrimanSefid2, Oct 26, 2008.

  1. AhrimanSefid2

    AhrimanSefid2 Guest

    I have created a database on sqlserver and want to connect to my database from my remote computer(my pc) but error is the result. the error is :

    TITLE: Connect to Server

    Cannot connect to myservername\sqlexpress.


    An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)

    My question is how can I connect to sql server database with managment studio from my remote computer(my local pc)? Is it possible?
  2. gongcart

    gongcart Guest

    1. sql server surface configuration manager: allow remote connection through TCP/IP and name pipes should be enable.
    2. setup the alias in sql browser through sql server configuration manager if you use sql browser service which is a memory hawk, if you disable it, you can connect to your sql server remotely with a port number at the end of your sql server ip address or subdomain you setup for sql server. For example, mssql.mysqlserver.com,1433. 1433 is the default port for sql server, you can always change that port.

    3. For security reason, please change "sa" default root username to something else after you login through management studio.

    4. Do not forget to open port that you use to connect to sql server on your firewall