1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL activated for every Subdomain

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by BenjS, Mar 6, 2012.

  1. BenjS

    BenjS Guest

    0
     
    ---------------------------------------------------------------
    Plesk 10.4.4 Update #19, Debian 5.0, x64

    I created the domain foobar.com and deactivated the SSL Support in the Power User view. Then I created a subdomain more.foobar.com, as I saw the SSL Support for the Subdomain was enabled.

    ACTUAL RESULT
    SSL support is enabled for every subdomain, even when I disable SSL Support in the service plan.

    EXPECTED RESULT
    SSL support should be disabled for every domain/subdomain, when SSL support isn't enabled in the service plan.

    ANY ADDITIONAL INFORMATION
    With this configuration, I get a lot of warn entries in the apache log:
    [Tue Mar 06 11:15:39 2012] [warn] Init: SSL server IP/port conflict: more.foobar.com:443 (/var/www/vhosts/more.foobar.com/conf/13310255520.58124800_httpd.include:10) vs. some.foobar.com:443 (/var/www/vhosts/some.foobar.com/conf/13310255620.88607500_httpd.include:10)
    --------------------------------------------------------------

    Is there any "best practice" for ssl? Can I combine one SSL site with multiple non-SSL sites on the same IP Adress? Or should I dedicate one SSL site on one IP and the other non-SSL sites to an other IP?

    Cheers,
    Benj
     
    Last edited by a moderator: Mar 6, 2012
  2. Dave.E

    Dave.E New Pleskian

    13
    35%
    Joined:
    Dec 3, 2011
    Messages:
    19
    Likes Received:
    0
    Same for me.

    Though the SSL-flag is OFF in the service plan - adding a new domain will have it ON in the domain's settings.


    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk Panel 10.4.4 MU#20
    CentOS 5
    Linux 2.6.18-194.26.1.el5xen
    PHP 5.3.3-1.el5_6.1 (updated with plesk update)
    MySQL 5.0.77-4.el5_6.6 (updated with plesk update)
    Apache 2.2.3-53.el5.centos.3

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    Adding a new domain will activate SSL for that domain although the SSL flag in the administration of the service plan is OFF

    ACTUAL RESULT
    SSL is turned on for new Domains

    EXPECTED RESULT
    SSL-option should be set according to the setting in the service plan
    --------------------------------------------------------------
     
Loading...