1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Strange SSL Problem

Discussion in 'Plesk 11.x for Linux' started by PhilNe, Dec 11, 2012.

  1. PhilNe

    PhilNe New Pleskian

    13
     
    Joined:
    Jan 30, 2012
    Messages:
    9
    Likes Received:
    0
    We bought an SSL certificate through aplha ssl per domain. we have these certificates installed and ssl checkers and desktops etc show the correct certificate. We have some facebook apps and we have reports of people not being able to use our app and get certificate warnings.

    Some devices are still showing the parallels certificate but the majority are displaying the correct one? my android phone recieves the parallels certificate but my desktop the aplha. Im not sure if it is only mobile devices that recieve the incorrect one but its not all mobiles as some in the office get the correct one.

    I have no idea where to begin solving this as everything seems fine from my desktop.

    Can anyone help?
     
  2. Dave W

    Dave W Basic Pleskian

    15
    35%
    Joined:
    Dec 11, 2012
    Messages:
    70
    Likes Received:
    2
    Hi PhilNe

    Had the same issue yesterday. You need to add the SSL to the server aswell and associate it to the IP address.

    Dave_W
     
  3. PhilNe

    PhilNe New Pleskian

    13
     
    Joined:
    Jan 30, 2012
    Messages:
    9
    Likes Received:
    0
    Thanks for the reply.

    where do i go to do that? also I believe this will cause more problems as we have 3 domains with 3 different ssl's so which ever one you associate to the ip will cause issues with the other 2.
     
  4. Dave W

    Dave W Basic Pleskian

    15
    35%
    Joined:
    Dec 11, 2012
    Messages:
    70
    Likes Received:
    2
    Hi PhilNe,
    My experience of this was a on plesk 10.4, Tools & Settings >> Tools & Resources >> SSL Certificates

    I copied the one form the domain and added it here.

    Then under Tools & Settings >> Tools & Resources >> IPaddresses I selected the SSL as the default for the domains IP.

    Each SSL requires a unique IP.

    Dave_W
     
Loading...