1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Suddenly web site needs login?

Discussion in 'Plesk for Windows - 8.x and Older' started by colinjack, Oct 25, 2005.

  1. colinjack

    colinjack Guest

    0
     
    Strange one .. one of the web sites on my server which has been fine and hasn't been touched for months, has suddenly started demanding a login (no anonymous access). Very strange ... all looks fine on the IIS properties etc. and all other web sites seem fine! The only thing I have done recently is update to 7.5.4 but that may just be coincedence.

    Anybody any ideas?

    Thanks
     
  2. jhankins

    jhankins Guest

    0
     
    same thing under 7.5.3

    I've seen a few times, not sure where it comes from. Both times I fixed like this:

    If it had FP exts, I removed and readded. Then went into FPAdmin link and did a repair permissions from there. That fixed it.

    On one occasion, I couldn't get into the FPadmin page and had to manually go in and remove .lck files (which an error message pointed me to that direction, I think complaining about reading a server.lck file.

    Note: I just did this today on a site that previously had not had FP exts. I added it, did the above. It fixed. Then removed them.

    Hope that helps. Post if it does or doesn't.
     
  3. siren@

    siren@ Guest

    0
     
    hmmm, long way. Check the IUSR_domain permissions on the httpdocs directory for the domain.
     
  4. colinjack

    colinjack Guest

    0
     
    The first thing I checked was the IUSR_domain permissions and these look fine (list, read and read&execute). Can't understand why this has suddenly happened.

    I will also look at the FP suggestion.

    Thanks
     
  5. colinjack

    colinjack Guest

    0
     
    Ummm ... not using FP on this site so ext disabled.
     
  6. jhankins

    jhankins Guest

    0
     
    ext disabled understood, renable then disable

    I know this sounds crazy, probably another way and yes I checked the domain permissions which seemed correct too on my sites. try enabling, then using fpadmin link from the domains control panel page and do the fix or repair permissions....test website. Should work, then you can remove fp exts.


    I'm sure someone will find a more precise solution but this has worked for me multiple times now. Not sure what the root cause for the change is either which would be nice to know.

    Jim
     
  7. VagaStorm

    VagaStorm Basic Pleskian

    24
    73%
    Joined:
    Sep 7, 2004
    Messages:
    73
    Likes Received:
    0
    I used t get this error all the time. I think switching ftp server where what permanently fixed it(I use gene6).

    To fix it:
    Set ftp password, then enter iis admin, properties for the domain, directory securety tab and press the button for authenthication access controll. set the anonymous password to the same as the ftp password. Stop and start the site, and it should be working agen :p
     
  8. colinjack

    colinjack Guest

    0
     
    Did all that and the health check says all is fine and dandy ... but it isn't ;)

    Still won't allow anon access.
     
  9. kami@

    kami@ Guest

    0
     
  10. colinjack

    colinjack Guest

    0
     
    Kami you genius .... its working again :D

    Many thanks. Really appreciated.

    Colin
     
  11. ecohosting

    ecohosting Guest

    0
     
    I'm hoping someone here can help.

    I'm going nuts trying to get my sites to work. The permissions seem to be totally out of whack. Nothing works! I keep getting "Unauthorized" from IIS. I have found lots of posts here about htis issue and I have tried all the recommendations. Nothing works!

    Any ideas?
     
  12. panaman

    panaman Guest

    0
     
    I had the exact same problem...
    but i am running plesk 7.5.6

    I assume that the problem would have been fixed in my version since the hot fix was for 7.5.4

    I ended up having to delete the site and recreate it in plesk.
     
Loading...