1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

sw-engine process eating up memory (not sw-engine-cgi issue)

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Sweet Lou, Oct 24, 2012.

  1. Sweet Lou

    Sweet Lou New Pleskian

    10
     
    Joined:
    Oct 15, 2012
    Messages:
    1
    Likes Received:
    0
    Hi all,

    We have been having some terrible spikes in memory that have crashed our server twice.

    After watching the processes I have found that there is a script that runs daily, but gets hung and the process doesn't stop. Then the same script is told to run the next day and so on until there are several of the same scripts running under different processes until the memory usage becomes too much for the server.

    Here is an example process when running ps aux:
    root 9221 0.0 3.5 247216 58800 ? S 10:34 0:00 /usr/bin/sw-engine -c /opt/psa/admin/conf/php.ini /opt/psa/admin/plib/DailyMaintainance/script.php

    To prevent this from taking over the server I have to manually kill the process each day.

    Does anyone have a solution or has anyone had a similar problem? Support (Igor) any help on this one?

    Any help would be greatly appreciated
     
Loading...