1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Symlinks problem

Discussion in 'Plesk for Linux - 8.x and Older' started by northernpaul, Aug 18, 2006.

  1. northernpaul

    northernpaul Guest

    0
     
    Hi,

    I have a Plesk server running a number of sites, and have had Awstats running fine for a number of months. The awstats scripts are stored in /usr/local, with symlinks created in each domain directory as as been shown elsewhere in the forums.

    In the past couple of days, Awstats has stopped working, saying I don't have permissions to access /awstats/awstats.pl on the server, and additionally a 403 Forbidden error was encountered when trying to use an ErrorDocument.

    I have checked through the vhosts.conf for the domains in question, checked the permissions in the awstats directories and even tried adding a .htaccess file with Option FolowSymLinks intothe domain root, and it still fails with the same error.

    I'm out of ideas of where to look next, and don't know if there is maybe some master config that is overriding the settings that I think should be working (Apache's not my strongest point...)?

    Any help greatly appreciated...
     
  2. Traged1

    Traged1 Guest

    0
     
    Did you ever get this issue fixed? We are having a similar issue but not for AwStats?
     
  3. northernpaul

    northernpaul Guest

    0
     
    Sadly not. We ended up altering the Awstats install script so that it placed a copy of the scripts into the domain it was being installed under instead of using symlinks.

    Sorry I can't be of much help...
     
  4. Traged1

    Traged1 Guest

    0
     
    Actually i did manage to figuire it out for anyone else looking in to this.

    PLESK writes to the httpd.include files

    By default plesk will not allow the +FollowSymlinks option.

    So we need to create a custom file named vhost_ssl.conf since you are trying to modify the config for the https folder on the domain. If you simply need it for the httpdocs folder you would create a file named vhost.conf

    This file is used when PLESK rebuilds the http.include files for each domain so that your changes do not get overwritten by PLESK.

    So I added the file: /home/httpd/vhosts/domain.com/conf/vhost_ssl.conf

    which contains the following;

    ---------------------------------------------------------------------------------------------
    <Directory "/home/httpd/vhosts/domain.com/httpsdocs">
    AllowOverride All
    Options +FollowSymLinks
    </Directory>
    ---------------------------------------------------------------------------------------------

    After sending PLESK the command to rebuild the conf files

    /usr/local/psa/admin/sbin/websrvmng -v -a

    and restarting httpd all is good and working great!
     
Loading...