1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

timefmt not working in SSI

Discussion in 'Plesk for Linux - 8.x and Older' started by MattElmore, Jun 9, 2006.

  1. MattElmore

    MattElmore Guest

    0
     
    SSI seems to be working fine, however the timefmt flags are not configuring the format
    Running on FreeBSD
     
  2. MattElmore

    MattElmore Guest

    0
     
    Found the cause, and a workaround for this. :cool:

    The cause:
    The apache 2.x branch breaks the timefrmt directive in .shtml files (note: the 1.3 branch is not affected). :mad:

    The workaround:
    Add the following to a .htaccess file in the site you want to use timefrmt to enable SSI parsing of .html files and then place your SSI calls inside a .html file. :)

    AddType text/html .html
    AddHandler server-parsed .html

    The drawback:
    All .html files will now be parsed for SSI thereby slowing down the site :(
     
Loading...