1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Trouble Shooting ASP "Internal Server Error"

Discussion in 'Plesk for Windows - 8.x and Older' started by ozcomm, Feb 20, 2005.

  1. ozcomm

    ozcomm Guest

    0
     
    Hello ... I can't get IIS to display the full ASP error message. All I get is the generic "Internal Server Error".

    Using Plesk 7.5 for Windows on a 2003 server. I am accessing the site via the Plesk site preview page (on the server console):

    "http://localhost/$sitepreview/site.com"

    I have turned off "Show Friendly HTTP Error Messages" in the browser. And enabled both ASP Server and Client-side script debugging for the site in question. No joy ... still get the generic Internal Server Error. This makes troubleshooting ASP pages very difficult.

    Any suggestions??

    Thanks.
     
  2. gianfranco

    gianfranco Guest

    0
     
    But, :confused:
    you are sure the installation is ok?

    Read the post after

    Gianfranco
     
  3. NxTek

    NxTek Guest

    0
     
    If you delete those custom error documents in IIS you will be able to see the "real" error.
     
  4. ozcomm

    ozcomm Guest

    0
     
    Sounds good ... but how? The IIS manager won't allow the deletion of the custom HTTP error pages. I can edit them (individually) and redirect them to another page, but i can not remove them.

    Assuming I am able to remove them (without a hack into the registry), after the site is stable I do not want clients to see any ASP error code (security precautions). So I would have to re-enter all the custom error codes? This was not necessary for Plesk 7.0 (windows). Is it a problem with 7.5?

    Thanks for your feed back!
     
  5. charper

    charper Guest

    0
     
    This is a feature of Plesk that is available in 7.0 and also 7.5. Under the sites physical hosting setup there is a feature called 'Custom Error Documents' that you have enabled that will not disclose the full ASP error message you are encountering. Disable this from the physical hosting setup of the site within Plesk and you should be all set.
     
  6. NxTek

    NxTek Guest

    0
     
    Go into IIS and look under the Custom Error tab. Set the ones that start with 500 from File to Default. Note the path of the ones that are currently File.

    Set them back to File after the site is stable.
     
  7. charper

    charper Guest

    0
     
    I wouldn't go in editing the customer error docs in IIS -- it's just going to muck up your Plesk installation because it won't recognize the configuration -- do what I said about and your problem will be fixed.
     
  8. NxTek

    NxTek Guest

    0
     
    I've been doing this for years without a problem.
     
Loading...