1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

turn off health monitor emails

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by joshua strebel, Nov 3, 2010.

Thread Status:
Not open for further replies.
  1. joshua strebel

    joshua strebel Guest

    0
     
    Where is the setting for turning off the emails for the new health monitoring system?
     
  2. H.W.B

    H.W.B Basic Pleskian

    24
    23%
    Joined:
    Apr 18, 2010
    Messages:
    66
    Likes Received:
    0
    i don't know where you can turn them off, but i have change the configuration file.

    I the health monitor the is an option to download the configuration file.

    When you have done open this file wilth an XML editor.

    There you will find values for serveral items.

    I have changed al 20 and 30 to 90 and 80.

    So the have to go to that percentage before there is an alarm (and an email)

    Henk
     
  3. zeroday

    zeroday Basic Pleskian

    23
    57%
    Joined:
    Jan 20, 2009
    Messages:
    34
    Likes Received:
    0
    Wonder why the Apache CPU is being put at 20 as my webserver with some weblogs (20 domains or so) from a new installation with plesk 10.01 gets 27% or something like that ..
     
  4. ugr|dual

    ugr|dual New Pleskian

    22
    57%
    Joined:
    Jan 30, 2009
    Messages:
    18
    Likes Received:
    0
    above 20% load from apache alone is a LOT.

    optimize apache.
     
  5. joshua strebel

    joshua strebel Guest

    0
     
    turn them off please..
    edited the xml file and pulled all the <alarm/> lines

    This is just a test service i just play around with with.. was emailing a few hundred notices a day.

    please add a "OFF" button for notificaiton
     
  6. Jonathan Spence

    Jonathan Spence Guest

    0
     
    OMG Yes add the ability to turn this off. Its is becoming chronic since the upgrade. I'm getting thousands of emails every day as the mail server CPU usage spikes even though the CPU sits around 10% for 99.99% of the time.
     
  7. JTRipper

    JTRipper Regular Pleskian

    27
     
    Joined:
    Mar 22, 2006
    Messages:
    106
    Likes Received:
    3
    Location:
    Italy
    any news here ??

    Igor, would you be so kind and paste here an example config of health monitor with this "notificationEmail" in use ?

    Or anything else in this config what disables email notifications ?

    Thanks in advance.
     
    Last edited: Aug 1, 2011
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    From /usr/local/psa/admin/conf/health-config.xml

     
  9. BoiseComputer

    BoiseComputer Regular Pleskian

    28
    23%
    Joined:
    Apr 14, 2006
    Messages:
    143
    Likes Received:
    5
    Location:
    Boise, Idaho
    Constant notifications!

    I would love to turn these off, but, why is CPU usage so high since the update? This has to be a Plesk issue. I don't want other things on my server being slow to respond or having issues because of a Plesk CPU usage bug. Please get this fixed rather than forcing us to ignore the problem.
     
  10. GearTalk

    GearTalk New Pleskian

    19
    35%
    Joined:
    Mar 16, 2010
    Messages:
    6
    Likes Received:
    0
    Please give us an option to turn off this horrid "experimental package". OR, give us a way to make it useful for goodness sake.

    I receive 300 emails a day -- EVERY DAY. My server administer and my webhost have been unable to turn this lousy thing off after 3 or 4 attempts.

    If you must keep it. Put it in the Control Panel where it can be disabled or set from the Control Panel. Yikes this is bad software!
     
  11. GearTalk

    GearTalk New Pleskian

    19
    35%
    Joined:
    Mar 16, 2010
    Messages:
    6
    Likes Received:
    0
    I hired a system specialist to kill it and they turned off the psa-health-monitor-notificationd service and set it for manual restart only. This has killed the notifications.
     
  12. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    This is on windows only as it is what is checked on and it is what I guess so far as if you are referring to that you want it off.

    Services -> Parallels System Heath Notifier

    Go to its properties and stop the service and mark startup type as disabled.

    Otherwise try updating on custom-health-config.xml file

    Find:
    <Misc alarmsInterval="5"/>

    Replace with:
    <Misc alarmsInterval="5" notificationEmail="off"/> (I don't know with this one about if it will work as you can guess and if it does let me know)
     
    Last edited: Nov 25, 2011
  13. JTRipper

    JTRipper Regular Pleskian

    27
     
    Joined:
    Mar 22, 2006
    Messages:
    106
    Likes Received:
    3
    Location:
    Italy
    Ryan, this way it won't work.

    If you need to modify section Misc of custom-health-config.xml to change the email address where the notices goes to please expand Misc key in that way:

    <Misc alarmsInterval="5" notificationSubject="The server have some problem">
    <notificationEmail address="myemailaddressforservernotifications@mydomain.tld" name="MyServerName"/>
    </Misc>

    It works for me even in Plesk 11 version.
    Certainly it does not turn off the notices at all, but when you consider also tweaking threshold values to 95 or 100 percent, it will make you get maybe 1 email in 2-3months or never depending of load of your machine.
     
  14. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Is there anyway to make the monitor check say 3 times over x minutes and only then send the notification? Currently, it sends a notification even for a momentary transient.
     
  15. pitsch

    pitsch New Pleskian

    6
     
    Joined:
    Dec 7, 2013
    Messages:
    2
    Likes Received:
    0
    In this file there is written:
    <!--#ATTENTION!
    #
    #DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
    #SO ALL YOUR CHANGES WILL BE LOST THE NEXT TIME THE FILE IS GENERATED.

    How do I change this file permanently?
     
  16. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  17. pitsch

    pitsch New Pleskian

    6
     
    Joined:
    Dec 7, 2013
    Messages:
    2
    Likes Received:
    0
    Thank you very much, it works
     
Thread Status:
Not open for further replies.
Loading...