• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question Turn off the garbage collector can not end up causing other problems?

Jonatan442

Basic Pleskian
(in PHP)

How can I access the php.ini to make the change?

Currently, 2 minutes before each hour, my site is unavailable. This happens hourly.

The problem is caused by PHP garbage collection.

The solution for you to solve the problem:
http://stackoverflow.com/questions/2904862/issues-with-php-5-3-and-sessions-folder

I need to know: turn off the garbage collector can not end up causing other problems?

Error message:
[Thu Aug 25 03:26:26 2016] [error] PHP Notice: session_start(): ps_files_cleanup_dir: opendir(/var/lib/php/session) failed: Permission denied (13) in /var/www/vhosts/site/httpdocs/qa-include/app/users.php on line 146
 
Last edited:
How can removing unused session files from a temporary directorythat are not actively doing anything cause a website to be offline for two minutes?
 
Back
Top