1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Two bugs in Plesk 10.3.1 (and below)

Discussion in 'Plesk 10.x for Linux Suggestions and Feedback' started by King555, Sep 9, 2011.

  1. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Three bugs in Plesk 10.3.1 (and below)

    These three bugs were in Plesk for a quite long time and still have not been fixed in 10.3.1 (with Microupdates installed):

    1.) The daily (or weekly, ...) mail of Watchdog always says "Watchdog is running since" and then the time of the mail sending. I always get the daily mail at 1 am and so I get "Watchdog is running since 01:00". This does not make sense, does it?

    2.) I changed the settings of the Health Monitor. But after an update it does not read my settings, although these settings are still saved (I can download them). The only solution: Download it, reset to system default and reupload. But why is this neccessary?

    3.) The Watchdog monitoring of "Plesk Web Server" does not work (it says, it is not running). But the Plesk Web Server is online, I can access Plesk at any time without problems.

    I use Debian 5.
     
    Last edited: Sep 11, 2011
  2. Kirill K

    Kirill K Regular Pleskian

    24
    53%
    Joined:
    Dec 24, 2007
    Messages:
    144
    Likes Received:
    0
    King555, thank you very much for your bug reports.

    We reproduced 1 & 3 problems.
    Could you help to us with 2nd problem? Next information will be useful:
    1. what debian do you use - x32 or x64?
    2. How did you perform upgrade (from which Plesk version)?
    3. Can you provide file with settings for Health Monitor?
     
  3. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Now I am not completely sure anymore, whether it's really a bug or not. But first of all, here are the requested things:

    1.) x64
    2.) I always upgrade to the very next version, i.e. 10.3.0 => 10.3.1 => 10.3.1 MU, I don't make bigger steps.
    3.) See attachment

    I can remember, that after one of the last updates (not the very last) I had to reupload my config file to make the Health Monitor work again with my settings.

    When I first used the Health Monitor, I got a lot of warnings via mail. Then I changed (doubled) the percent values of the Apache CPU and RAM usage, which should be allowed (and changed the interval to 30 minutes).

    Then I got a very small amount of mails for some time. After the last update I got many mails again. So I thought it's that bug again and I posted it here. But now I reuploaded the configuration and I still get those mails. So maybe it's not that bug anymore.

    But my CPU usage is maximum 25-30% during the day and I get mails with Apache CPU usage Red and Yellow (which means 50 and 40 percent, if the HM reads my config).

    So now you have to decide, whether there is some kind of bug.
     

    Attached Files:

  4. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Issues 1 and 3 are still not resolved with the very latest version of Plesk. Will they be fixed in one of the next updates?
     
  5. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    The two bugs are still not fixed (Plesk webserver monitoring and sending time of Watchdog mail).
     
  6. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Bug 3 is still not fixed (Plesk webserver monitoring). I currently use Debian 6.0.9 x64 and latest Plesk 11.5.
     
  7. King555

    King555 Regular Pleskian

    22
    90%
    Joined:
    Jan 5, 2011
    Messages:
    177
    Likes Received:
    3
    Location:
    Germany
    Last edited: Aug 25, 2014
  8. bepgasrinnai

    bepgasrinnai New Pleskian

    3
     
    Joined:
    Sep 8, 2014
    Messages:
    1
    Likes Received:
    0
    I think this is a dangerous bug, it can do more damage to the system. Thank you king555 did report
     
Loading...