1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to change default site for shared IP

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by JaredF, Jul 27, 2011.

  1. JaredF

    JaredF Guest

    0
     
    I am unable to change the default site for a shared IP. I am running 10.3.0 but also had this issue with 10.1.1 on Ubuntu 10.04.

    Steps to reproduce:

    1) Create original.example.com on IP
    2) Create new.example.com on IP
    3) Tools & Utilities > IP Addresses > Select IP > Select new.example.com for Default site drop down

    Open IP in browser and it will display original.example.com for IP, which is wrong

    4) Domains > original.example.com subscription > Suspend

    Open IP in browser and it will display new.example.com for IP, which is correct

    5) Domains > original.example.com subscription > Activate

    Open IP in browser and it will still display new.example.com for IP, which is correct

    6) Tools & Utilities > IP Addresses > Select IP > Select original.example.com for Default site drop down

    Open IP in browser and it will display original.example.com for IP, which is correct

    7) Tools & Utilities > IP Addresses > Select IP > Select new.example.com for Default site drop down

    Open IP in browser and it will display original.example.com for IP, which is wrong (see step 4 and 5 to fix)

    I'm pretty sure this is a bug. I've tried tracing the Apache config files but it gets real tricky real fast. Although the hacky deactivation trick works above I'd be great to figure out what is going on here. I'm thinking it might have something to do with the load order for the various configuration files.

    Cheers.
     
Loading...