• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Unable to configure webserver after fresh install

VPS_Plesk

New Pleskian
Hello,

at first: Plesk make the administration of dedicated or virtual servers a lot easier. Thanks for this convenience.

I'm using Plesk 12.5 on a VPS with CentOS 7. After a fresh install of the whole OS, I get the following information: "Unable to configure a web server on the host...."

To be more specific:
Template_Exception: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 27 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load modules/mod_cache_disk.so into server: /etc/httpd/modules/mod_cache_disk.so: undefined symbol: ap_cache_cacheable_headers_in

file: /usr/local/psa/admin/plib/Template/Writer/Webserver/Abstract.php
line: 75
code: 0

When I login via Plesk I regenerate the config files. After that the server is unreachable over ports 80, 443, 8443. Login via SSH and

Code:
/usr/local/psa/admin/sbin/httpdmng --reconfigure-all

doesn't show any error messages or something like that.
 
It is better to use

# plesk repair web

in case of Plesk 12.5 version.
 
Hello IgorG

thanks for your help.

# plesk repair web

doesn't change the state. Server is only via SSH accessible.
 
What is output of following commands:

# httpd -V
# ls -la /etc/httpd/conf/httpd.conf

?
 
Output: # ls -la /etc/httpd/conf/httpd.conf

# -rw-r--r-- 1 root root 11961 Apr 19 20:54 /etc/httpd/conf/httpd.conf

Output httpd -V:
 

Attachments

  • Unbenannt.png
    Unbenannt.png
    260.5 KB · Views: 3
Try to disable this module with

# /usr/local/psa/admin/sbin/httpd_modules_ctl -d disk_cache

and then

# /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
 
I've made a fresh install with Debian 8 and Plesk and there are no problems. I don't know why Plesk doesn't work with CentOS at my provider :confused:
 
Back
Top