1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

unable to connect mssql webadmin

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by yatint, Jul 25, 2011.

  1. yatint

    yatint Basic Pleskian

    19
    60%
    Joined:
    Aug 2, 2010
    Messages:
    91
    Likes Received:
    0
    Hello,

    I am not able to connect mssql webadmin.
    I created virtual dir for sqladmin
    also given permission to IIS user

    Page got stuck at mssql/app/connect.aspx.

    Also please tell me how to remove mylittleadmin feature from plesk 10.2

    Please assist
     
  2. yatint

    yatint Basic Pleskian

    19
    60%
    Joined:
    Aug 2, 2010
    Messages:
    91
    Likes Received:
    0
    Here is the error :

    Error Summary
    HTTP Error 405.0 - Method Not Allowed
    The page you are looking for cannot be displayed because an invalid method (HTTP verb) is being used.

    Detailed Error Information
    Module StaticFileModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x80070001
    Requested URL http://mssql.xxxx.xxxx:80/mssql/app/connect.aspx
    Physical Path C:\Inetpub\vhosts\sqladmin\mssql\app\connect.aspx
    Logon Method Anonymous
    Logon User Anonymous
    Failed Request Tracing Log Directory C:\inetpub\logs\FailedReqLogFiles

    Please assist...
     
  3. GabS

    GabS Guest

    0
     
    Hello,

    It seems to be an issue with handler mappings of your mssql webadmin site in IIS.
    seems that the extension is restricting verbs its allowed to process.
    open your IIS, double click on site so that it will open feature view, click on Handler Mapping > it will list all added handlers > in right pane either click on the handler in question or just right click on pane and select "Edit Feature Permissions..." > enable Execute.
    Or if you select a specific handler then double click on it and select "Request Restrictions..." > Verbs > select "All Verbs" > and click Ok

    Regards,
    sysadmin
     
  4. yatint

    yatint Basic Pleskian

    19
    60%
    Joined:
    Aug 2, 2010
    Messages:
    91
    Likes Received:
    0
    Thanks sysadmin...

    But still I am getting same error.....
     
  5. yatint

    yatint Basic Pleskian

    19
    60%
    Joined:
    Aug 2, 2010
    Messages:
    91
    Likes Received:
    0
    Last edited: Jul 29, 2011
  6. GabS

    GabS Guest

    0
     
    its now giving you option to login as I can see login box over there.
    The errors you are getting on this page can be fixed by making few changes in script.

    Regards,
    sysadmin
     
  7. yatint

    yatint Basic Pleskian

    19
    60%
    Joined:
    Aug 2, 2010
    Messages:
    91
    Likes Received:
    0
    While opening IIS application pool I am am getting below error :

    PHP Warning: call_user_func_array() expects parameter 2 to be array, string given
    Line: 1080
    File: C:\Program Files (x86)\Parallels\Plesk\admin\plib\elements.php3
    Stack Trace:
    #0 Smb_Exception_Syntax::handleError(2, call_user_func_array() expects parameter 2 to be array, string given, C:\Program Files (x86)\Parallels\Plesk\admin\plib\elements.php3, 1080, Array ([name] => status, => on.gif,[conhelp] => Dedicated IIS application pool is enabled.,[direct_conhelp] => ,[skin] => Skin Object ([] => ,[] => Array (),[] => ,[] => ,[attr] => Array ([id] => 1,[name] => Default,[place] => default),[changableAttr_] => ,[oldAttr_] => Array ([id] => 1,[name] => Default,[place] => default),[errorAttr] => Array (),[reqAttr] => Array ([0] => name),[Table] => SkinTable Object ([tables] => Array ([0] => Skins),[fields] => Array ([0] => id,[1] => name,[2] => place),[] => Array ([id] => 2),[] => mysqli_result Object ([current_field] => ,[field_count] => ,[lengths] => ,[num_rows] => ,[type] => ),[] => ,[id] => 1,[idAttrIndex] => 0,[where] => ,[order] => ,[error_] => ,[errorMsg_] => ,[warnArr_] => Array ()),[needUpdate] => ,[idFieldName] => id,[] => ,[error_] => ,[errorMsg_] => ,[warnArr_] => Array ()),[i_handlers] => ))
    #1 call_user_func_array(Array ([0] => Tooltip,[1] => key), Dedicated IIS application pool is enabled.) called at [C:\Program Files (x86)\Parallels\Plesk\admin\plib\elements.php3:1080]
    #2 comm_icon(status, on.gif, Dedicated IIS application pool is enabled.) called at [C:\Program Files (x86)\Parallels\Plesk\admin\plib\iis\class.IIsAppPoolForm.php:99]
    #3 IIsAppPoolForm->assign(IIsAppPoolMode Object ([_old_mode] => mixed,[_mode] => mixed,[error_] => ,[errorMsg_] => ,[warnArr_] => Array ()), IIsAppPool Object ([_node] => DOMElement Object (),[_websrvmng] => WebServerManager Object ([restart_] => 1,[options_] => Array (),[features] => Array ([WEB_Server_package] => iis,[WEB_Server] => Microsoft IIS,[WEB_FPAdminSysUser] => 1,[WEB_Performance] => 1,[WEB_MimeTypes] => 1,[WEB_VirtualDirs] => 1,[WEB_VirtualDirsFastCGI] => 1),[error_] => ,[errorMsg_] => ,[warnArr_] => Array ()),[_type] => 0,[_id] => ,[_inputableAttr] => Array ([0] => cpuUsage),[_errAttr] => Array (),[_enabled] => 1,[error_] => ,[errorMsg_] => ,[warnArr_] => Array ()), pool) called at [C:\Program Files (x86)\Parallels\Plesk\admin\plib\ui_common\IISAppPoolUIPointer.php:186]
    #4 IISAppPoolUIPointer->accessItem(GET, ) called at [C:\Program Files (x86)\Parallels\Plesk\admin\plib\UIPointer.php:600]
    #5 UIPointer->access(GET) called at [C:\Program Files (x86)\Parallels\Plesk\admin\htdocs\plesk.php:57]


    Please assist
     
Loading...