• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Unable to receive verp replies in Plesk 10.4.4 qmail

rjshelq

New Pleskian
Using Plesk 10.4.4 mu#18 I am unable to receive any verp encoded replies. With an older server running Plesk 8.3, I have no problem receiving verp encoded replies. Qmail is properly sending out verp encoded reply addresses with 10.4.4, but I am not able to receive any bounces and/or replies.

In accordance with qmail-users and dot-qmail documents (and exactly like I did on the old 8.3 server) I added a wildcard assignment in /var/qmail/users/assign having the general form:

+2-joe-mlist:popuser:110:31:/var/qmail/mailnames/domain.net/joe:-:mlist:

and provided .qmail files for:

joe/.qmail
joe/.qmail-mlist-reply
joe/.qmail-mlist-reply-default
joe/.qmail-mlist-owner
joe/.qmail-mlist-owner-default

with each file containing:

| true
| /usr/bin/deliverquota ./Maildir

However any incoming email arriving with an address of the verp form:

[email protected]

is rejected with a message saying "smtp;550 sorry, no mailbox here by that name. (#5.7.17)"

Email to [email protected] works fine, but despite the wildcard assignment in /var/qmail/users/assign, any address with anything following joe is rejected.

I very desperately need to find a solution for this, in order to efficiently process the verp bounces and replies. Any help will be greatly appreciated..... Any ideas???
 
Solution

After considerable turmoil and tail-chasing, it turns that there is an easy fix for this problem.

In "Mail"-"Change Settings"-"Mail Settings", I simply changed "What to do with mail sent to nonexistent users" from "Reject" to "Bounce with message" and now Plesk pays attention to the /var/qmail/users/assign statements.

Apparently, when "Reject" is selected, Plesk does not pay attention to the /var/qmail/users/assign statements, and rejects users on the basis of something else.

But when "Bounce with message" is selected, then the /var/qmail/users/assign statements are employed, and the verp addresses are happily accepted.
 
Back
Top