1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

unable to run perlscripts suexec not allowing it I've tried everything

Discussion in 'Plesk for Linux - 8.x and Older' started by crankin, Feb 7, 2006.

  1. crankin

    crankin Guest

    0
     
    I've read everythread about suexec, and cgi scripts and can't seem to get perl scripts running. My server is running SuSE 9.1 Plesk 7.5 and Apache2 with mod_perl2. My scripts work perfectly on my testserver running mepis, but no scripts are running on my main server. I've tried copying psa_suexec over suexec, chown user:psacln, etc, etc. When I run my script I get the following error in my suexec log:

    [2006-02-07 11:06:04]: uid: (10001/remguru) gid: (10001/10001) cmd: test
    [2006-02-07 11:06:04]: command not in docroot (/home/httpd/vhosts/house-remodeli
    ng-contractor.com/cgi-bin/test)

    so I ran suexec -V and there was no output so then I ran psa_suexec -V got no out put so then i ran apache2_psa_suexec -V and it said the doc root was /srv/www/htdocs so I coped this over suexec (mind you I'm in /usr/sbin/) ran my scripts and copied my test script in /srv/www/htdocs for good measure same error in the log.

    I really don't know what else to do, and I don't really want to re-install apache because I'm new with plesk, and I'm not sure how it will effect the setup. Any suggestions? Thanks in advance.
     
Loading...