• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

unable to ssh

Khoi_Nguyen

New Pleskian
i'm using plesk 12.5. when i try to ssh i get this error

OpenSSH_6.9p1, LibreSSL 2.1.7

debug1: Reading configuration data /Users/khoinguyen/.ssh/config

debug1: /Users/khoinguyen/.ssh/config line 1: Applying options for *

debug1: Reading configuration data /etc/ssh/ssh_config

debug1: /etc/ssh/ssh_config line 20: Applying options for *

debug2: ssh_connect: needpriv 0

debug1: Connecting to 104.154.88.217 [104.154.88.217] port 22.

debug1: Connection established.

debug1: identity file khoinguyen.pub type 1

debug1: key_load_public: No such file or directory

debug1: identity file khoinguyen.pub-cert type -1

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_6.9

ssh_exchange_identification: read: Connection reset by peer

only happens with 12.5
 
You may have been banned by fail2ban or /etc/hosts.deny
Check it.
 
Hi Khoi_Nguyen,

ssh_exchange_identification: read: Connection reset by peer

please update/upgrade your used SSH - Client, or use another one, because OpenSSH is removing support for "Diffie-Hellman group exchange" in old formats.

Please be reminded, that your issue does not depend to any Odin / Plesk - product, the issue is caused by your used SSH-client and the OpenSSH - version on your server and the depending SSL - libraries.
 
Back
Top