1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to update hosting preferences: hosting update is failed: object ID is invalid

Discussion in 'Plesk for Linux - 8.x and Older' started by Synoptic, Dec 9, 2007.

  1. Synoptic

    Synoptic Guest

    0
     
    When i'm trying to create a new domain - after updated to 8.1.1 and to 8.2 (was getting hte same error before updating to 8.2). I get this error : Unable to update hosting preferences: hosting update is failed: object ID is invalid.

    This happens when I want to create a physical hosting. After getting the error, the somain is listed, but still need to be setup. Going back to the setup of the domain, I get the same error.

    I would like to know if there is a log file in which I could look in. By experience, this error is a result of a database query not being completed - missing something.
     
  2. ib1984

    ib1984 Basic Pleskian

    23
    70%
    Joined:
    Jun 25, 2008
    Messages:
    91
    Likes Received:
    0
    Looks like update didn't went well and database is inconsistent. There are several signs of failed upgrade:

    1) two installed 'psa' rpms -- old one and new one
    2) versions of rpm and /usr/local/psa/version do not match
    3) there are errors in upgrade logs in /tmp/

    If update had failed it should be rolled-back to previous version and re-done.
     
  3. Synoptic

    Synoptic Guest

    0
     
    Ok, how do I troubleshoot this ? How do I revert back ?

    Which package is mostly causing this ?
     
  4. ziba@

    ziba@ Guest

    0
     
    Here is the deal: in order to troubleshoot this problem you should find initial error that caused it.
    So firstly check /tmp/autoinstaller3.log (Plesk update log) for error messages. If you find any paste them here.

    Generally troubleshooting of problems with issues in changing database during update include the following:
    1. Create dump of current database state (just in case)
    2. Restore preupgrade database dump. It is usually stored in /var/lib/psa/dumps
    3. Run upgrade once again by downloading Plesk distribution tarball from ftp://download1.swsoft.com/Plesk. unpacking it and installing appropriate packages using "rpm -Uvh --force" command
    Note: base Plesk packages are in ../base and directories of tarball. ../opt directory contains optional packages (modules, etc).

    It is for you to decide but I'd rather check updater logs first prior to applying this troubleshooting scheme.
     
  5. Synoptic

    Synoptic Guest

    0
     
    My log file does not contain the initial problem in it. I deleted the file before I got aware of the problem.
     
  6. Synoptic

    Synoptic Guest

    0
     
    Ok, I found the problem. I have mounted a new disk under the vhost directory, but I had forgotten to move the .skel directory.

    I didint know that there was the httpsd log file in the psa admin directory, this would have saved me 10 hours.
     
Loading...