1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unexpected server behaviour.

Discussion in 'Web Presence Builder' started by BoiseComputer, Feb 24, 2012.

  1. BoiseComputer

    BoiseComputer Regular Pleskian

    28
    23%
    Joined:
    Apr 14, 2006
    Messages:
    143
    Likes Received:
    5
    Location:
    Boise, Idaho
    Error
    Unexpected server behaviour.
    Please contact the server administrator.


    When someone goes to edit their site from inside of Plesk they receive this error in Web Presence Builder. This seems to have happened after an upgrade.. What can I do? There is no way to get around it other than sites I am converting from SiteBuilder 4.5. I can click that and get around it.
     
  2. MarshallS

    MarshallS Guest

    0
     
    I have the exact same issue. I upgraded my install from 10.3.3 to 10.4.4 and now it has that error and then you can click ok and it loads the page but there are no options to choose from in the 2 columns.
     
    Last edited by a moderator: Feb 24, 2012
  3. BoiseComputer

    BoiseComputer Regular Pleskian

    28
    23%
    Joined:
    Apr 14, 2006
    Messages:
    143
    Likes Received:
    5
    Location:
    Boise, Idaho
    This is in my sitebuilder.log

    2012-02-24T20:33:10-07:00 [EMERG] [System] /sitebuilder/Start?token=<Bunch of letters and numbers> SB_Application_Exception_NotAuthorized: Invalid token has been provided
    file: /usr/local/sb/include/SB/Controller/Plugins/Sb/Auth.php

    This is the error...
     
  4. custer

    custer Administrator Staff Member

    33
     
    Joined:
    Apr 24, 2007
    Messages:
    593
    Likes Received:
    101
    Hi,

    This issue is not currently known by our team, so it requires detailed investigation. I would really appreciate if you could PM me with details. Thanks!
     
    Last edited: Feb 27, 2012
  5. sebgonzes

    sebgonzes Regular Pleskian

    27
    90%
    Joined:
    Feb 2, 2009
    Messages:
    122
    Likes Received:
    6
    Same error message after last microupdate!
    In error_log :
    2012-03-06T10:12:03+01:00 [EMERG] [System] /sitebuilder/JsonApi/ Zend_Cache_Exception: Could not determine temp directory, please specify a cache_dir manually
     
  6. JP Kelly

    JP Kelly Regular Pleskian

    28
     
    Joined:
    Jan 20, 2007
    Messages:
    168
    Likes Received:
    0
    Same thing here

    I have the same problem.
    A client pointed it out to me and now I need to fix it ASAP!
     
  7. JP Kelly

    JP Kelly Regular Pleskian

    28
     
    Joined:
    Jan 20, 2007
    Messages:
    168
    Likes Received:
    0
  8. JP Kelly

    JP Kelly Regular Pleskian

    28
     
    Joined:
    Jan 20, 2007
    Messages:
    168
    Likes Received:
    0
    How to determine which version of sitebuilder is used

    How can we specify which version of Sitebuilder the Plesk panel uses?
     
  9. custer

    custer Administrator Staff Member

    33
     
    Joined:
    Apr 24, 2007
    Messages:
    593
    Likes Received:
    101
    Hi everyone,


    We are aware of this issue and we're trying to pinpoint the exact root cause, so we can fix it in a microupdate. Can you tell me, does this problem happen only on Debian installations?
     
  10. custer

    custer Administrator Staff Member

    33
     
    Joined:
    Apr 24, 2007
    Messages:
    593
    Likes Received:
    101
    Fix

    Hi everyone,

    If you experience "unexpected server behavior" error after upgrade to 10.4.4, here's the way to fix it:

    1. Back up /usr/local/sb/include/SB/Site.php
    2. Replace /usr/local/sb/include/SB/Site.php with the file in attached patch
    3. Repeat the process for every affected server

    Thank you.
     

    Attached Files:

  11. skamerica

    skamerica Guest

    0
     
    Unexpected server behaviour

    I can not find the file "/usr/local/sb/include/SB/Site.php" and, when I try to publish my site from within the Web Presence Builder 10.4.4, I receive the following:
    Error
    Unexpected server behaviour.
    Please contact the server administrator.

    Furthermore, my site banner is showing in the builder but not showing when the site is viewed in a web browser. This is getting very frustrating. So, please provide me some guidance.
    Lastly, I use Mac OS X Lion as my operating system, Web Presence Builder used to load just fine using Safari and now it only loads using Firefox. Again, this is very frustrating. Please help.
     
  12. custer

    custer Administrator Staff Member

    33
     
    Joined:
    Apr 24, 2007
    Messages:
    593
    Likes Received:
    101
    Hi Skamerica,


    Just to clarify: are you a hoster or you're a customer who bought hosting and uses WPB?
     
  13. VitaliiB

    VitaliiB Guest

    0
     
    same issue

    Hello,

    We have the same issue.

    > If you experience "unexpected server behavior" error after upgrade to 10.4.4, here's the way to fix it:
    >
    >1. Back up /usr/local/sb/include/SB/Site.php
    >2. Replace /usr/local/sb/include/SB/Site.php with the file in attached patch
    >3. Repeat the process for every affected server

    After this fix we have following error:

    c:\Program Files (x86)\Parallels\Plesk\sb\htdocs\index.php belongs to the 9 version of Plesk

    Please advice.
     
  14. custer

    custer Administrator Staff Member

    33
     
    Joined:
    Apr 24, 2007
    Messages:
    593
    Likes Received:
    101
    Hi VitaliiB,


    This patch is only for Linux version of WPB as the problem was actual only for several Linux distros, at least to our knowledge. It is possible that you were trying to fix a completely different problem with the same symptoms, so the patch obviously didn't help. I suggest you to roll back the changes, upgrade to WPB 11 and if your particular problem persists, PM me with details so I can help you out. Thanks.
     
Loading...